1. helpmeplease22's Avatar
    Hi. I have a Samsung Galaxy S2. Since upgrading from Gingerbread 2.3.4 to Jelly bean 4.1.2, I cannot connect to 5g wifi. I can connect to 2g wifi no problem.

    Before the upgrade, I could connect easily to 5g wifi on Gingerbread. My partner also has a Samsung Galaxy S2 on Gingerbread and they continue to be able to connect to 5g wifi on the same router.

    I have tried manually entering the SSD and password, but no change. Sometimes, the phone does not detect the 5G signal on the scan for wifi networks, but other times it will. When I try to connect to 5g wifi, it will sometimes flash for a split second like it is connecting but then it will just say "saved, secured" or sometimes authentication error.

    Help ! I thought I was doing a good thing by upgrading, but it looks like I have just downgraded!!!
    12-17-2014 10:47 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Go to Settings>Wi-fi, tap Menu, then Advanced. Do you see an option for "Wi-Fi frequency band"? If so, make sure it's set to "Automatic," which should be able to detect both 2.4 GHz and 5 GHz bands.
    helpmeplease22 likes this.
    12-18-2014 01:51 AM
  3. helpmeplease22's Avatar
    Thanks B.Diddy. Unfortunately, I had already tried that but it didn't work. When I upgraded to Ice Scream Sandwich, I couldn't get 5g whatever band I chose (2.4g only, 5g only, or automatic). So I upgraded again to Jelly Bean, hoping that would solve it, but still no 5g. So annoying.
    12-18-2014 01:32 PM
  4. Old Stoneface's Avatar
    Try changing the 5GHz channel the AP or router is using. One of the home theater devices we have wouldn't connect to my 5GHz WLAN, either, until I tried a differet channel.

    It is 2.4GHz and 5GHz, btw, not merely "g". It's a frequency range/band designation, not a "generational" one.
    12-18-2014 02:22 PM
  5. helpmeplease22's Avatar
    Thanks Stoneface. I had tried that too - i had heard that certain channels are more likely to work with Jelly Bean so I tried those (if available) on my wifi (am on Virgin Media Superhub). Alas, big fat nothing again.

    Yes, sorry, I am being lazyby just typing 2/5g instead of full 2.4/5 ghz...
    12-19-2014 12:16 PM

Similar Threads

  1. bluetooth issue since update
    By asylvia in forum Motorola Droid Turbo
    Replies: 4
    Last Post: 12-18-2014, 03:54 PM
  2. WIFI is "stuck"? android 4.1.2
    By Kevin Kayotic in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 6
    Last Post: 12-18-2014, 10:22 AM
  3. Why am I not able to connect to wifi?
    By Kaushik Das3 in forum Ask a Question
    Replies: 2
    Last Post: 12-17-2014, 05:23 PM
  4. Why is my wifi connection showing "Disabled"?
    By Buff2014 in forum General Help and How To
    Replies: 1
    Last Post: 12-17-2014, 12:08 PM
  5. Why does my wifi automatically disabled if mobile data is on?
    By Nubnuber in forum General Help and How To
    Replies: 1
    Last Post: 12-17-2014, 11:14 AM