1. John Danz Jr's Avatar
    So I got a 64GB microSD for my phone. It corrupted pretty much any picture I saved to it, but strangely enough videos I saved to it will play. Apps saved to it force stop immediately. So I tried the card in two other phones and it worked like a charm. What is going on with my phone that won't let me do this? It accepts SD's up to 128GB.

    Phone is an HTC Desire 816 running 4.4, rooted.
    12-28-2014 09:25 PM
  2. Rukbat's Avatar
    Bad motherboard, bad SD card socket, bad firmware? If it's under warranty (it should still be) have it replaced.
    12-28-2014 10:17 PM

Similar Threads

  1. App Locker has taken over my Tablet!
    By leapa in forum Ask a Question
    Replies: 4
    Last Post: 04-14-2015, 02:41 PM
  2. Google voice apps no longer work at all since update
    By karensk in forum Google Nexus 10 Tablet
    Replies: 1
    Last Post: 01-10-2015, 01:12 AM
  3. Moved apps to SD card, available device storage virtually unchanged?
    By MattPSU79 in forum Samsung Galaxy Tab4 7.0
    Replies: 7
    Last Post: 12-31-2014, 03:37 AM
  4. Cool phone but I feel I can't use it. ARGH!
    By bfranker in forum Motorola Droid Turbo
    Replies: 5
    Last Post: 12-29-2014, 10:40 AM
  5. How do I get pictures on my gallery on my Gear 2 Neo?
    By Julie Basham in forum Ask a Question
    Replies: 0
    Last Post: 12-28-2014, 08:40 PM