1. Kbos51's Avatar
    Hi
    I'm trying to root my galaxy s3 but have been unable to connect it to my pc in debugging mode. I've done tons of research and have tried every solution I could find but to no avail. I've done everything from reinstalling usb drivers, kies to powering on/off while connected, plugging in while in download mode, as well as several other things. Developer options are turned on and debugging option box is checked. My Windows 7 PC sees it only as a media device. In the notifications panel, touch for more options only gives me the option to connect as camera. I'm at a loss. I am using a data and not a charging only cable. I've switched usb ports, tried different computers, I'm stumped and frustrated... kinda hard to root it if i can't copy anything to it. Thank you in advance for your help
    12-29-2014 05:15 AM
  2. Golfdriver97's Avatar
    Welcome to the forums. In developer options, try clicking revoke USB debugging authorization, then reconnect to your PC.
    12-29-2014 09:14 AM
  3. Kbos51's Avatar
    I've revoked while connected then reconnected, while disconnected then reconnected, and also revoked then rebooted and reconnected but to no avail nothing seems to work.
    12-29-2014 03:50 PM
  4. Golfdriver97's Avatar
    I am not sure what else to suggest. Sorry.

    From an AOSP M8
    12-29-2014 04:23 PM
  5. Kbos51's Avatar
    Is a possible reason the 4.4.2 update?
    I caught a blurb about a boot lock or something..can't find where I saw it at.
    12-29-2014 08:55 PM
  6. Golfdriver97's Avatar
    Is a possible reason the 4.4.2 update?
    I caught a blurb about a boot lock or something..can't find where I saw it at.
    Possible. Now that you mention it, I recall hearing something along the same lines....since I no longer have a Samsung I didn't pay much attention.

    From an AOSP M8
    12-29-2014 09:29 PM
  7. Rukbat's Avatar
    What are you using to root it? If the kernel date (Settings/General/About device/Kernel) is before June 3, 2014, just install Towel Root and press the "Make it rain" button and the phone will be rooted - no PC needed.

    BTW, 4.4.2 itself doesn't interfere with debug mode - I just connected adb to my Note 3 running 4.4.2 with no problem. There could be a problem with 4.4.2 on the S3, but I haven't seen any questions about it.
    12-29-2014 09:40 PM

Similar Threads

  1. Saying Hi To My New Galaxy S5
    By JohnYx Sorilla in forum New to the Forums? Introduce Yourself Here!
    Replies: 11
    Last Post: 01-06-2015, 03:18 AM
  2. Galaxy s5 unlock
    By angelisawesome in forum T-Mobile
    Replies: 15
    Last Post: 01-05-2015, 12:42 AM
  3. Replies: 1
    Last Post: 12-29-2014, 08:32 PM
  4. Replies: 1
    Last Post: 12-29-2014, 03:57 AM
LINK TO POST COPIED TO CLIPBOARD