1. Garin Juniar's Avatar
    My tablet is lenovo a8-50 on kitkat os and the problem is it wont charge or connect to desktops, basically it wont do anything that use usb connection, when I plug it to my charger the battery icon doesn't show that its charging but its actually charging because the battery level is rising, and when I connect it to my pc and laptop its just say that my device isn't recognized, so the question is does anyone have any idea what is causing my problem and how can i fix it ??
    thank you and sorry for the broken english
    01-14-2015 11:43 AM
  2. Paul627g's Avatar
    Have you tried the obvious, a new or different USB cord/cable?
    01-14-2015 12:01 PM
  3. Garin Juniar's Avatar
    Yes i have tried other charger other cable other power socket other usb port from other pc. still no luck.
    I'm roooted by the way
    01-14-2015 12:06 PM

Similar Threads

  1. Internal Memory at Capacity - Changing MicroSD Card Help
    By MrsDowFire in forum Samsung Galaxy S5
    Replies: 15
    Last Post: 01-16-2015, 11:08 AM
  2. Can I get some help fixing my Samsung GS3?
    By LilNinja5181 in forum General Help and How To
    Replies: 2
    Last Post: 01-14-2015, 01:21 PM
  3. S4 to PC connection fail.
    By Ben Floris Robberecht in forum Samsung Galaxy S4 Active
    Replies: 2
    Last Post: 01-14-2015, 12:26 PM
  4. Please i need answer about root
    By Essam H in forum LG G2
    Replies: 1
    Last Post: 01-14-2015, 11:45 AM
  5. Rooted nexus 5 unable to register on AT&T
    By Jakedo508 in forum Ask a Question
    Replies: 0
    Last Post: 01-14-2015, 10:20 AM