1. AC Question's Avatar
    Recently my phone would randomly shut down but it would then restart without issue. Yesterday however, my phone shut down and wouldn't turn back on. When I plug it in, will either not respond or the battery symbol will show as loading and then stop. When I press the power button, sometimes nothing will happen or sometimes it will show Samsung and then Samsung S3 and sometimes it will even go further to the coloured circle Samsung and then stop. But a few times it went past that even and went to my home screen except the date and time were incorrect and once over the past 24 hours, I was able to open my gallery and I saw that all my pictures were still there. I was also able to connect to wifi once but each time I try again, it will shut down after a few minutes or seconds. I've obviously tried removing the battery and trying again, I've even tried using someone else's battery. Also I've tried turning on my phone in download mode or recovery mode but it doesn't work.
    01-26-2015 11:43 AM
  2. belodion's Avatar
    Have you tried getting into Recovery from Settings as well as via the hard buttons?

    Posted via the Android Central App
    01-26-2015 03:41 PM
  3. B. Diddy's Avatar
    Welcome to Android Central! Was your friend's battery fully charged?

    When you say that tried Recovery Mode, did you actually get to the Recovery Menu? If so, did you wipe the cache partition? http://forums.androidcentral.com/sam...2-s3-tab2.html
    01-26-2015 03:55 PM
  4. leahbaya's Avatar
    I actually got my phone to turn on, but as soon as I clicked on settings, it shut down again.
    01-26-2015 07:45 PM
  5. leahbaya's Avatar
    no, when I try holding down the buttons, either nothing happens, or it just starts turning on as usual, but shuts down before its turned on completely most of the time.
    01-26-2015 07:50 PM
  6. B. Diddy's Avatar
    And is your friend's battery fully charged? How old is that battery?
    01-26-2015 09:30 PM
  7. leahbaya's Avatar
    yes I'm pretty sure it was fully charged or close to fully charged. and his battery isn't more than a year old.
    01-26-2015 09:44 PM
  8. B. Diddy's Avatar
    There might be some loose power connection somewhere, either with the battery or with the Power button. The only other thing I can think of trying is to remove the SD card and reboot, in case the card is corrupt. Otherwise, you may have to bring the phone to a repair shop.
    01-26-2015 10:36 PM

Similar Threads

  1. "Device Management is ..." won't go away
    By AlphaVictor87 in forum HTC One M8
    Replies: 8
    Last Post: 06-03-2016, 04:08 PM
  2. YouTube app on Dell venue 8 7000
    By jrb7561 in forum Dell Venue 8 7000 Series
    Replies: 13
    Last Post: 04-26-2015, 07:12 PM
  3. Replies: 1
    Last Post: 01-26-2015, 04:10 PM
  4. Replies: 2
    Last Post: 01-26-2015, 04:06 PM
  5. my samsung galaxy 10.1 wont charge why?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-26-2015, 01:56 PM