1. Ken Regular's Avatar
    Recently I bought the ZTE Grand X (Z933) on the Bell Canada network.

    It has a Qualcomm Snapdragon 200 quad-core processor, running Android 4.3. I want root access but so far I have not been successful.

    Framaroot is supposed to be able to root the Snapdragon 200 using the Gandalf exploit. However, when I run Framaroot, it only offers the Aragon exploit (which does not work). Framaroot does not include Gandalf in the list.

    Also tried Kingo Root but it was not successful in obtaining root access. I received a form letter from Kingo saying they will get back to me if they find a way to root this device (I am not optimistic that I will hear from Kingo again.)

    Has anyone on this forum successfully rooted this device? Please tell me how.
    01-30-2015 01:13 PM

Similar Threads

  1. Lollipop....Worth the update ?
    By cjp40 in forum Samsung Galaxy S5
    Replies: 8
    Last Post: 02-01-2015, 10:49 PM
  2. How can I unlock the memo widget if I forgot the password?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-30-2015, 01:32 PM
  3. I-9502 bought from merimobiles, wont work in the US?
    By Liora Yukla in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 01-30-2015, 01:22 PM
  4. What happen to the extra data I purchased?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 01-30-2015, 01:17 PM