1. AC Question's Avatar
    I wonder if you can help me with this one!

    I have an S3 GT-I9305 that was running on jellybean (not sure which version). I recently revieved a push message to update my OS to
    kitkat. After it downloaded I was asked to approve the installation
    which I did.

    Once the installation reaches 100% the phone restarts, displays the model name and then starts installing the update again in a continuous loop. It does this until the battery is flat. I have taken the battery out for 10 minutes, but on turning the phone on it starts the installation again and enters the loop.

    I have tried entering safe mode by holding down the power, home and
    volume+ buttons, this causes the phone to restart, but doesn't get me
    into safe mode. The loop continues.

    I have tried the above method, but taking my finger off the power button when the model name and number is displayed - does nothing.
    There is no vibration or anything. The loop continues.

    I just want to go back to jellybean (which came on the device) and get my phone back! I'm willing to risk losing data to do some kind of reset.

    Any assistance would be appreciated.

    02-11-2015 03:16 AM
  2. Rukbat's Avatar
    The over the air update is warrantied - IOW, if the carrier bricked your phone by sending it an update, they're responsible for fixing it. Bring it to the carrier.
    02-11-2015 12:14 PM

Similar Threads

  1. Replies: 10
    Last Post: 02-12-2015, 07:00 AM
  2. Replies: 1
    Last Post: 02-11-2015, 07:38 PM
  3. Why won't my Galaxy S3 turn on?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 02-11-2015, 10:58 AM
  4. Replies: 0
    Last Post: 02-11-2015, 02:59 AM