1. AC Question's Avatar
    My tablet's battery went out, so I plugged it into the charger. It wouldn't turn on. All it showed was a battery sign with a loading symbol, then it would shut down, then it showed a battery symbol where a part of it was covered in blue, and the it would shut down. I tried rebooting it and I tried holding down the up and down volume button, but nothing worked. What should I do?
    02-17-2015 12:42 PM
  2. belodion's Avatar
    Get the battery tested. It probably needs replacing....or there may be some other fault, which will need proper diagnosis.

    Posted via the Android Central App
    02-17-2015 01:24 PM
  3. Golfdriver97's Avatar
    To add to belodion's post, you might just want to try letting it charge for a few hours without trying to turn it on. The battery may be so depleted that it needs that long just to turn on.
    02-17-2015 01:27 PM

Similar Threads

  1. Replies: 3
    Last Post: 11-01-2015, 01:37 AM
  2. Why can't I print PDF's saved on Phone?
    By RobIV01 in forum Samsung Galaxy Note 4
    Replies: 7
    Last Post: 02-20-2015, 12:58 PM
  3. Replies: 2
    Last Post: 02-17-2015, 02:04 PM
  4. Replies: 0
    Last Post: 02-17-2015, 12:15 PM
  5. Replies: 0
    Last Post: 02-17-2015, 12:14 PM