1. Joe De Toro's Avatar
    My zte awe got messed up so I energy went into recovery mode and cleared cache. My phone was able to boot up after and worked fine until I restarted the phone a few days later. I tried to boot up the police but it wouldn't go so I did the recovery and cleared cache. During the process the phone froze longer than it should have and was unresponsive. I took the battery out and put it back in. The phone never turned on since. Completely unresponsive. My pc still recognizes it but I don't know what to do. Is this a dead phone or can it be fixed.

    P.s. I don't think it's a hardware issues as there was no damage to the phone only software. The phone wasn't routed either
    02-18-2015 04:29 PM

Similar Threads

  1. Replies: 2
    Last Post: 03-21-2015, 12:49 AM
  2. Replies: 2
    Last Post: 02-18-2015, 07:00 PM
  3. Does anyone have a ZTE Blade Q Mini?
    By Jong Lourney in forum Ask a Question
    Replies: 1
    Last Post: 02-18-2015, 11:54 AM
  4. zte z730 t mobile cwm or twrp
    By Billy Messenger1 in forum Ask a Question
    Replies: 1
    Last Post: 02-16-2015, 09:07 PM
  5. Replies: 1
    Last Post: 02-14-2015, 11:05 PM