1. anon9349476's Avatar

    I downloaded an app from Google Play. Things started happening with the tablet so I tried to uninstall it, but there was no way to do so. I tried to uninstall it through the tablet app settings and the Google Play store, but there's no option to uninstall it, there is no button that says "uninstall" anywhere. I also downloaded a separate app uninstaller to uninstall it, but it said that the tablet has to be rooted and that I had no root access.

    I'm confused because this was not a preinstalled app, I downloaded it. So why is it suddenly showing up as a system app? I can't even disable it, the disable button is greyed out. I also went through the file manager and deleted the folder. The app keeps coming back on it's own.

    I then did a factory reset through the tablet settings. It was still there. I tried a factory reset lots of times (I lost count). I thought that maybe it was because it was automatically reinstalling from the internet so I did another factory reset, but this time I skipped the step to connect to wifi so that the tablet was not connected to the internet at all. The app was still there. This lousy app has somehow attached itself to the firmware.

    I also held down the power and volume buttons until a list of options came up. One of the options was to delete the cache. I did, no change. I also tried the factory reset through this method of holding down the physical buttons, but the app is still there.

    I contacted the developer of the app and the tablet manufacturer. No response from the manufacturer of the tablet. The developer sent an automated we got your message, we'll contact you shortly reply, but shortly never came and I was never contacted. I contacted Google and they said the tablet was rooted and I had to call the manufacturer. More confusion for me because the tablet is not rooted. So now I'm thinking this app is malware.

    I scanned it with Kaspersky anti-virus for android, but it didn't find anything.

    Am I basically out of luck?

    Again the manufacturer won't reply. The developer won't reply. I get the feeling Google doesn't want to touch this. I'm being ignored

    I'm frustrated because this app was one of the top rated apps in the Google Play store so I was stupid and assumed nothing would go wrong and that the app was safe.

    I can't get the tablet back to it's original factory state because the app has attached itself to the firmware somehow.

    The tablet has android 4.4.2, is a digiland tablet, and the app is the "Clean Master" app.

    I would greatly appreciate any help.
    03-02-2015 07:09 PM
  2. srkmagnus's Avatar
    Go into system settings > applications > sort by all > clean master. From that menu, you should have the option to uninstall. That should work. If it doesn't, then the app may have been pre-loaded and can't be uninstalled.
    03-02-2015 07:18 PM
  3. anon9349476's Avatar
    Thanks for the reply.

    When I do that on the top there is a "force stop" button on the left and a greyed out "disable" button. Nothing that says "uninstall."

    The app was not pre-loaded, it was downloaded from the Google Play store.
    03-03-2015 06:35 PM

Similar Threads

  1. Replies: 1
    Last Post: 03-13-2015, 12:07 AM
  2. How do I protect apps from uninstallation?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-02-2015, 06:35 PM
  3. Replies: 1
    Last Post: 03-02-2015, 06:33 PM
  4. My Cubot X6 screen is black with bandsm how can I fix this?
    By To Bartolo in forum Ask a Question
    Replies: 1
    Last Post: 03-02-2015, 06:30 PM
  5. My Galaxy S4 is stuck on the boot, how do I get out of it?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 03-02-2015, 05:08 PM