1. AC Question's Avatar
    I was attempting to root my phone, and well, things went wrong. I used Odin 3.09 and attempted to downgrade my phone from Android 4.4.4 to the May 2014 version of 4.4.2 so that I could use Towelroot because it doesn't work on 4.4.4. Upon using Odin, which said it was successful, I started my phone, it boots, says "Samsung" and then goes black, but the blue notification light stays on and fades in and out for eternity. Any help would be greatly appreciated!!!
    03-05-2015 11:44 PM
  2. GreenghostUvln's Avatar
    If u are already using Odin why didn't u just use that to easily root your phone on any android version.

    Sent from my T-Mobile Galaxy S4 rockin 5.0.1
    03-06-2015 03:22 AM
  3. Rukbat's Avatar
    Don't panic. (I've been trying out new ROMs this week, and I must have bricked my phone at least a dozen times. Boring, waste of time, not a problem, though. I had the long blue light about 3 times.)

    Make sure you have the 4.4.2 for the AT&T S5, not some other model S5. Boot to download and flash it again. SamMobile Firmwares has 4.4.2 for the phone. Or I'm sure you can find it on the AT&T S5 forum at XDA Forums.
    03-06-2015 11:41 PM
  4. habeebsamawi's Avatar
    i have the same problem right now , i flashed my at&t stock firmware but nothing happens its still the same , it worked before but now it doesnt even samsung until now they didn't know how to fix it
    04-28-2015 02:53 PM

Similar Threads

  1. Replies: 5
    Last Post: 04-21-2015, 09:21 AM
  2. How do I make the passwords stored on my tablet visible?
    By Cheviot in forum General Help and How To
    Replies: 4
    Last Post: 03-29-2015, 10:48 PM
  3. Great battery life on my moto g 2
    By Aniket Mhatre in forum Moto G
    Replies: 5
    Last Post: 03-19-2015, 11:01 AM
  4. Does samsung galaxy grand duos 2 support MHL HDMI?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-06-2015, 11:49 AM
  5. Replies: 1
    Last Post: 03-06-2015, 08:10 AM