1. AC Question's Avatar
    I have an unlocked, GSM model Nexus 4. Yesterday I tried taking it into a Cricket store to buy service using their "bring your own device" offering, which specifies that all you need is an unlocked, GSM phone.

    However, after inserting the SIM card, the phone was unable to pull the correct APN settings, and I was unable to manually enter them as the APN setting screen said that "Access Point Name settings are not available for this user." Normally, you only see that screen when you don't have a SIM card in your phone. We tried rebooting but no luck.

    My phone is running Android 5.0.1 (Lollipop), and the associate admitted they didn't really know what they were doing. Should I just go back and try again with someone else today, or is there something I can do?
    03-13-2015 09:29 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Did they try a different SIM?

    Just in case, here's the help page: https://www.cricketwireless.com/supp...n-android.html
    03-13-2015 10:21 AM
  3. Charles Davis1's Avatar
    I am having the same issue. I received a 2nd generation Moto G before switching to Cricket. The Moto G is laggy and not as smooth as the Nexus 4. I thought I could put the sim in and go but that didn't work. I too, took mine to the Cricket store and they had the same problem putting in the APN settings. Did you get your Nexus 4 on Cricket?
    03-23-2015 08:33 PM

Similar Threads

  1. How do you stop deleted emails from returning?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 03-13-2015, 11:40 AM
  2. Why doesn't my led notification light work on my LG Tribute?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-13-2015, 10:49 AM
  3. Replies: 1
    Last Post: 03-13-2015, 10:33 AM
  4. How can i check my recent calls?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-13-2015, 08:52 AM