1. jkl113's Avatar
    I've had my Droid Razr M for a couple years now, and haven't had a single problem until today.

    First, I plugged the phone in to charge and it rebooted. It loaded the battery charging screen that you get if you plug your phone in while it's turned off. The battery was still charging, but I couldn't do anything with the phone unless I unplugged it and rebooted.

    Now, a few hours later, when I plug it in it reboots and gets stuck in a constant reboot loop. It loads the "M" screen that you see when you first turn the phone on, then crashes and reboots again, over and over.

    I've tried different chargers and different outlets. If I plug it into my computer it will boot up, but does not charge (I don't think it ever did on the computer), which is the main issue. The phone works fine when it is not plugged in, but will not charge.

    I've tried freeing up more memory and booting in safe mode and still had the same problem. I tried to clear cache partition using the instructions on Motorola's website, but got stuck on the "Android in Distress" logo and could not get any further. I manually cleared the cache on all apps and that did not work. I contacted Motorola but they want me to pay $150 to send it to their repair center - no way!

    Any ideas? The only remaining thing I can think to do would be a factory reset, and I really don't want to do that unless I'm certain it will work!
    03-21-2015 09:57 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! The behavior you describe makes me think the problem lies with the microUSB port, so I doubt a factory reset would help.
    03-21-2015 10:00 PM
  3. jkl113's Avatar
    Is there any way to fix or replace it? Other than getting a new phone, of course.

    Unless there's some sneaky magical way to charge the phone without using the microUSB . . .
    03-21-2015 10:06 PM
  4. B. Diddy's Avatar
    Didn't find any DIY videos on YouTube. I did find this, though: Motorola Droid RAZR M Charging Port Repair | Genius Phone Repair | Grand Rapids MI. $70 for a repair. Not that you have to use them--but it gives you a ballpark figure for the cost.
    jkl113 likes this.
    03-22-2015 01:49 AM

Similar Threads

  1. How do I turn off Time to work and home on Samsung Galaxy S4?
    By AC Question in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 03-21-2015, 11:17 PM
  2. Can I go back to 4.4.2?
    By Edible Walrus in forum Samsung Galaxy S4
    Replies: 2
    Last Post: 03-21-2015, 10:50 PM
  3. Why has my Droid Ultra stopped charging with no warning?
    By AC Question in forum Motorola Droid Ultra
    Replies: 1
    Last Post: 03-21-2015, 09:08 PM
  4. How can I get the notifications on my galaxy gear?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 03-21-2015, 07:01 PM
  5. Flashed to Boost Mobile Sprint Note 3 ROM?
    By Elomeli27 in forum Samsung Galaxy Note 3
    Replies: 0
    Last Post: 03-21-2015, 06:41 PM