1. AC Question's Avatar
    The basic clock app has corrupted since the upgrade to Lollipop, and I cant use the alarm, stopwatch, world clock etc

    I can't find the app anywhere to download again.

    Everytime I press on the Clock icon, it very quickly says "Unfortunately, Clock has stopped"

    I then I have to press OK

    Help please, I need my alarm!

    Thanks in advance
    04-09-2015 04:47 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Try going to the App Manager, select Clock, and Clear Cache/Clear Data. Now try again.

    If that doesn't work, try wiping the system cache partition: http://support.t-mobile.com/docs/DOC-5744
    04-09-2015 05:09 PM
  3. SM422's Avatar
    Thank you for the suggestions

    However, I have tried both without success

    Any further suggestions?
    04-10-2015 01:05 AM
  4. B. Diddy's Avatar
    Try Safe Mode, to see if it's due to some 3rd party app that is interfering. Steps are at the bottom of this article: http://support.t-mobile.com/docs/DOC-5744
    04-10-2015 10:06 AM
  5. davel33's Avatar
    I reset my phone to factory and it still does this.
    05-06-2015 10:38 AM
  6. blue_drgn's Avatar
    I'm having the same issue.
    05-07-2015 11:52 AM
  7. Chad Beeton's Avatar
    Similar issue here. Clock will stop moving forward randomly. Even after factory reset. Tried a 3rd party clock app, it did the same thing.
    05-07-2015 03:52 PM
  8. Planehopr's Avatar
    ***********Update*************POSSIBLE SOLUTION


    I just called Verizon Wireless tech support back. The guy had seen this problem once before and found a fix for it. I haven't seen this fix posted on any website, but it worked immediately. Please let me know if this works for you

    Go to Settings--Date and Time--Select Date Format, and then choose a date format. Once I picked 'regional' the clock worked without the error "unfortunately, clock has stopped"

    Before I tried clearing cache and doing a factory reset You don't have to do this if this "choose date format" works. Please comment and let me know if this helped you. I'm curious if this will work across the board. Maybe even for phones other than Samsung Galaxy S4. I'm stoked!
    jcamp-loyal2galaxy likes this.
    05-09-2015 05:18 PM
  9. AngieC43's Avatar
    Setting the date to Regional worked for me. Thanks!
    Planehopr likes this.
    05-10-2015 05:11 AM
  10. Spygirl7's Avatar
    Yes, I set the date format to regional and the clock worked again. I was even able to change it to other date formats after that and it still worked. I was worried because I had already cleared the data from the clock app and no longer had my alarm set for tomorrow. Thanks!
    Samsung Galaxy S4, now on Lollipop.
    05-18-2015 02:21 AM
  11. jcamp-loyal2galaxy's Avatar
    It worked for me! Thank you!!!!
    Planehopr likes this.
    05-26-2015 01:41 AM
  12. Q Hert's Avatar
    It worked for me!!! Thank you
    06-05-2015 05:19 PM
  13. Lisa Gregg's Avatar
    Setting it to regional worked! !! Thank you thank you.
    06-15-2015 12:23 AM
  14. atanasova's Avatar
    Thank you. It worked!
    06-16-2015 03:14 AM

Similar Threads

  1. Camera Update on the way
    By htcrazy in forum HTC One M9
    Replies: 30
    Last Post: 04-15-2015, 12:41 PM
  2. How to override automatic power saving at 5% battery life
    By Adthay in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 04-10-2015, 03:00 PM
  3. Why does my phone seem to change pin itself?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-09-2015, 05:13 PM
  4. Replies: 0
    Last Post: 04-09-2015, 04:37 PM