1. AC Question's Avatar
    Hi, I had rooted my S4 Mini last month, using towelroot, following the YouTube video, "How To Root A Samsung Galaxy S4 Mini (Verizon)"

    That had worked successfully.

    But then Verizon issued an OTA update from March 30th 2015.

    Consequently my phone was then unrooted. When I tried to root it again using towelroot again, this time towelroot does not work. Towelroot says "This phone isn't currently supported".

    Any idea of another way I can root my phone now?

    Thank you
    04-16-2015 09:10 AM

Similar Threads

  1. Device takes too long to turn on
    By David Bent in forum General Help and How To
    Replies: 10
    Last Post: 04-19-2015, 09:55 PM
  2. How does Multi Window work??
    By Jalopiejoe in forum Samsung Galaxy Note 3
    Replies: 6
    Last Post: 04-18-2015, 12:47 AM
  3. can anyone help me to resolve my phone error
    By Anshu Singh1 in forum Samsung Galaxy Grand
    Replies: 1
    Last Post: 04-16-2015, 08:16 PM
  4. How do I stop TXT notifications on my Galaxy S4?
    By AC Question in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 04-16-2015, 07:55 PM
  5. Replies: 1
    Last Post: 04-16-2015, 07:52 PM