1. AC Question's Avatar
    Hey all I've read all of the threads here about this topic and have tried:
    -setting my wi-fi to always on, even when screen is off
    -changing pandora auto-lock setting, both on and off
    -checking app settings for any restrictions (none)
    -uninstalled/reinstalled Pandora
    -uninstalled/reinstalled advanced task killer
    -made sure there were no blockages/restrictions within the task killer for Pandora

    Now when I shut the screen, Pandora will finish the song, but it will not play the next song. Any ideas where to go from here?
    04-25-2015 08:52 AM
  2. VW Maverick's Avatar
    Welcome.
    Uninstall the task killer and/or battery saver apps and try it again.
    If it works, it has to be a setting in one of those.
    Let us know how it goes.

    Mav.
    04-25-2015 08:56 AM
  3. Robert Stengel's Avatar
    I was having the same issue while playing through the phone speakers, headphone, or external bluetooth speaker and it was driving me crazy. There doesn't seem to be much out there in the way of explanations/fixes so here's my two cents and so far seems to have corrected the issue.
    Open Pandora and then Settings>Advanced>Screen Auto-Lock select the Conserve battery box mine was unchecked and now it is checked.
    Hope this works for you
    05-14-2015 10:14 AM
  4. Robert Stengel's Avatar
    Please forgive me and my amateur ways. My suggested "fix" in the previous post does NOT solve the issue.
    05-28-2015 12:02 PM
  5. aminoi's Avatar
    I think there is a bug in Samsung version of the battery saver process which is interfering with the streaming of Pandora:


    Try the following steps and let me know if it works:-

    1. Close Pandora
    2. Turn on the ultra power saver mode.
    3. Once all the apps are updated for the ultra power saver....... just switch back to regular mode..

    I tried this and it worked....The worst part is that you need to do it every time pandora freezes
    05-29-2015 05:50 PM
  6. Brandie m's Avatar
    Im having the same issue. I uninstalled it 3 times and nothing. Now it wont even play. Also, now im having trouble sending msgs. That it sits there pending to send.
    03-22-2016 10:43 PM
  7. Tuka Rachid's Avatar
    I had the same problem but i fixed it!!
    Serrings> system > battery > more (top right corner) > optimize battery usage > all apps (top left drop down)

    I then scrolled down to pandora and turned it off.
    05-19-2016 02:19 PM
  8. Jermaine_Robinson's Avatar
    I don't want to jinx myself, but I think you're right. It's that battery power saving thing. TURN IT OFF. Jesus I almost bought a new phone.
    05-19-2016 09:20 PM
  9. Gesyka79's Avatar
    This has been driving me nuts for weeks. Your fix worked! Thank you!

    Mine was slightly different to find it though: Settings > Battery > Battery Usage > More (top right corner) > optimize battery usage > all apps

    I had the same problem but i fixed it!!
    Serrings> system > battery > more (top right corner) > optimize battery usage > all apps (top left drop down)

    I then scrolled down to pandora and turned it off.
    07-04-2016 01:44 PM
  10. Raeven72's Avatar
    THANK YOU!!

    I've been battling this issue for MONTHS. Also considered scrapping the phone or Pandora.

    This fix of turning off battery saver for the Pandora app works immediately, even while Pandora is running.

    I had Pandora running while browsing this forum. The next song wouldn't play unless the app was active, and then when I made it active, it would skip a song and play the next. I read this fix, went to battery settings, made the change and came back here without touching Pandora itself. When the next song came, it played without issue. Did not have to restart anything.

    I'm sending this link to Pandora. This is crazy.

    Thank you again!! This is going to help me get back into my workout routine. So really, it's kind of life changing.


    UPDATE: Went to Pandora help to double check before reporting this and found that this solution is now listed for having trouble streaming on Android. I'm certain that was not there before because I've definitely looked.

    Thanks again!
    08-20-2016 01:44 PM
  11. ismail A's Avatar
    Hey all I've read all of the threads here about this topic and have tried:
    -setting my wi-fi to always on, even when screen is off
    -changing pandora auto-lock setting, both on and off
    -checking app settings for any restrictions (none)
    -uninstalled/reinstalled Pandora
    -uninstalled/reinstalled advanced task killer
    -made sure there were no blockages/restrictions within the task killer for Pandora

    Now when I shut the screen, Pandora will finish the song, but it will not play the next song. Any ideas where to go from here?
    i had the same problem because i had power saver mode if you turn it off it works fine.
    10-07-2016 12:14 PM

Similar Threads

  1. Replies: 4
    Last Post: 04-28-2015, 06:37 PM
  2. Samsung Stratosphere Call Lag
    By legsilver in forum Samsung Stratosphere
    Replies: 1
    Last Post: 04-25-2015, 07:11 PM
  3. What to do next after rooting the S2 using Kingo Root?
    By Lavret in forum Samsung Galaxy S II
    Replies: 1
    Last Post: 04-25-2015, 06:52 PM
  4. Replies: 1
    Last Post: 04-25-2015, 08:38 AM
  5. Cracked screen and problems with Google now
    By Aimee Orion1 in forum Motorola Droid MAXX
    Replies: 1
    Last Post: 04-25-2015, 08:21 AM
LINK TO POST COPIED TO CLIPBOARD