1. AC Question's Avatar
    Hello. As the title says, I need help flashing a recovery to my Sony Xperia Z Ultra (c8606) with unlocked bootloader. I have tried using FlashTool to flash the TWRP img file found on their website. I connect the phone to fastboot mode, click on Select Kernel to Flash, and select the file labeled: twrp- The file flashes, but always softbricks my phone (The LED light flashes red when it is plugged in, and holding down the power button only causes the phone to vibrate briefly every couple seconds). This forces me to re-flash a FTF file (C6806_14.5.A.0.242_Customized USA.ftf) to unbrick. I have tried flashing other kernels (108_DualRec_Jackie099) and other FTF files (C6806_14.3.A.0.681 US_Unbranded.ftf), with the same result.

    Can anyone tell me what the problem is and what do I do? I want TWRP recovery installed on my phone (preferably the one found on their website), but everything I have tried just bricks my phone.

    Please help me!
    04-25-2015 06:40 PM

Similar Threads

  1. Replies: 2
    Last Post: 06-24-2016, 12:42 PM
  2. Apps are closing on start - no force close
    By Roxshot in forum Legacy Android & Other OS's
    Replies: 4
    Last Post: 04-25-2015, 11:31 PM
  3. Why isn't my Note 2 connecting to my pc?
    By AC Question in forum Samsung Galaxy Note 2
    Replies: 1
    Last Post: 04-25-2015, 07:04 PM
  4. Replies: 1
    Last Post: 04-25-2015, 06:29 PM
  5. Replies: 0
    Last Post: 04-25-2015, 06:21 PM