1. BebosDG's Avatar
    Please its urgent, i bought this tablet thinking i could record more HD quality videos, but i cant seem to root it. I havent found a root for it.

    Help please xD
    05-23-2015 02:12 PM
  2. VE3UND's Avatar

    Having been looking for this information myself i'm sharing real quick here what i've found. Scouring the net all over i've found NOTHING specific for these Chinese tablets but after finally getting on the scent of VROOT I downloaded and tried iROOT essentially a one-click rooter the .APK **DID NOT WORK** but the PC version **DID** can be found by googling iroot or vroot.

    RE: bootloader, i've still found no way or any good info on entering the bootloader AFAIK this is locked and may not be possible without some good hard hacking on the firmware, I DO KNOW that if you try entering the "bootloader" with a reboot manager on the device u will find yourself at the "NeuTab" welcome screen and stuck. Fortunately at least in my experience, letting the tablet battery run down low you can boot back into it and root condition is still good.

    Hope this helps somewhat I know its an old post but a lot of people have been looking for this info have yet to post on authors site confirming that the NeuTab also works with his software.


    BTW I forgot to mention the site and the software (ALTHOUGH IT STATES OTHERWISE) is in Chinese. A leap of faith needed there I know but i confirm this method works. l8z
    BTW^2 ALSO the android version was KitKat as received from the mfg, also have been told that Jellybean will install on the tablet after rooting and maybe is now included with device but don't quote me on that.
    all in all a really nice tab for the price, especially now we have root biggest missing option: GPS but you can tether to another device with gps if you need to. Also no built in USB HOST MODE. //out
    07-18-2015 05:35 PM
  3. chrishibbard7's Avatar
    Hi! So glad I found your post.

    I just got a NeuTab N10 Plus in today, and am trying to root it. I followed the suggestions in your post, and the iRoot PC USB link method LOOKS like it worked (found device on USB, copied daemon, rebooted device, waited for it to come back up, then is said, "Root Complete". But:
    when I try to run su from terminal, it can't be found.
    when I run SuperSU app, it says the su binary is missing and can't copy it
    when I run Root Checker, it says I don't have root access.
    when I open a terminal and try to enter \root dir, terminal says I don't have permissions.

    ANy advice? This thing shipped with Android 5.1.1 and it seems like there are some Android 5.x su problems?

    I'm also receiving a Galaxy S5 in the mail next week, and want to root it also. Any advice appreciated. What's all the hype about Knox I'm hearing? I haven't rooted anything for 2 yrs, since my S4 first came in.

    09-19-2015 10:16 PM
  4. VE3UND's Avatar
    Can't say for sure since my device is a N7 not an N10 but one basic thing to ask you:

    can you access via ADB from your pc via wifi or usb??

    if so do this at command shell assuming adb installed in \adb on C drive

    c:\cd \adb
    c:\adb usb
    c:\adb root
    c:\adb shell
    # su
    ^ if it doesnt change to $ or you get any error messages make sure you have proper usb drivers installed then try again.

    c:\cd \adb
    c:\adb\adb remount
    c:\adb\adb shell
    # su
    ^ ??
    You can also try KINGOroot apk or KingoRoot pc apps on googleplay and respective web sites they should be updated.
    luck++ Dunno what Knox is googling it now...cheers
    04-13-2016 10:12 AM

Similar Threads

  1. anyone flash 5.1.1 yet? (and rooted after?)
    By sibeans in forum Google Nexus 4
    Replies: 1
    Last Post: 05-29-2015, 08:01 AM
  2. how root samsung t700
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 05-24-2015, 02:46 AM
  3. Replies: 1
    Last Post: 05-23-2015, 04:11 PM
  4. Rooting
    By Evan Mohr in forum Ask a Question
    Replies: 2
    Last Post: 05-23-2015, 10:47 AM
  5. Replies: 0
    Last Post: 05-23-2015, 10:30 AM