1. AC Question's Avatar
    Although the Uber website specifies that its app is compatible with the Samsung Galaxy Star 4.1 range, when I try to install the app I keep getting the message that the device is not compatible with this app. The only reason I bought this phone is to use Uber, so this is very frustrating.
    05-31-2015 06:49 AM

Similar Threads

  1. Replies: 2
    Last Post: 10-17-2015, 05:44 PM
  2. Moving back to andoird after nearly 5 years with windows phone!
    By Oliver Newell in forum New to the Forums? Introduce Yourself Here!
    Replies: 22
    Last Post: 06-20-2015, 07:11 PM
  3. Replies: 3
    Last Post: 05-31-2015, 10:45 AM
  4. Why doesn't my screen unlock with my PIN?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 05-31-2015, 08:02 AM
  5. My Android box will not install Kodi why is that?
    By AC Question in forum General Help and How To
    Replies: 0
    Last Post: 05-31-2015, 05:28 AM
LINK TO POST COPIED TO CLIPBOARD