1. AC Question's Avatar
    My phone does not connect to my office wifi from last 2 months but my laptop still does connect.
    My phone says "Authentication error" for office wifi but works well with home and other wifi.
    However my friend can connect to same office wifi from his phone so i think its not wifi issue
    07-01-2015 10:05 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Which phone? Does your office have an IT department? Have you asked them about this?

    One quick thing to check is to make sure the phone's date and time exactly match that of the office's network. There can sometimes be a slight discrepancy, but that may be all it takes to prevent you from connecting.
    07-01-2015 10:34 PM
  3. arunbansal509's Avatar
    Moto G2
    no IT dont look into mobile devices issue here.
    Date and time is perfect.
    After entering the same password as in laptop; mobile says saved then "Authentication Problem"
    I have googled it and found so many people have reported it.
    But how come for other users on same android version its working on same router i'm accessing.
    07-02-2015 01:03 AM
  4. B. Diddy's Avatar
    Have you already tried forgetting the network, then connecting again? Also, it doesn't require a proxy, does it?
    07-02-2015 01:11 AM
  5. arunbansal509's Avatar
    Yes tried forgetting the network and tried with aeroplane mode too.
    No proxy is needed.
    My friend is connected directly just by entering password.
    07-02-2015 01:17 AM
  6. arunbansal509's Avatar
    Any solutions anyone...
    07-02-2015 07:55 PM
  7. B. Diddy's Avatar
    Unfortunately, the solutions I'd suggest would involve actually having access to the router's settings. Since your IT isn't particularly helpful, then I'm not sure what else to suggest. If you want to be a bit naughty, you could look for the router nearest to you and reboot it by unplugging its power for 10 seconds, then plugging it back in.
    07-03-2015 01:06 AM
  8. arunbansal509's Avatar
    router access is not possible.
    I'll keep looking for the solution
    07-03-2015 03:10 AM
  9. arunbansal509's Avatar
    can you tell me the router settings.
    I can update the router details if required.
    07-21-2015 05:56 AM
  10. nahoku's Avatar
    Might be a certificate. Contact your IT and ask if a security cert is required for the wifi. Even if your IT isn't too helpful, they should at least give you that info.
    This article might help... How to Add Security Certificates on Android | Chron.com

    Edited to add info found in a Nexus thread...

    I was able to fix my problem. Work has been busy so I haven't been able to return. I don't know exactly what fixed it, but this is what settings my phone was at prior to the issue, and what fixed it:

    my phone had developer options turned on, prior to the update, and remained on (or i turned it on after the update, i cant recall).

    1.) I cleared my browser data, all of it - saved passwords and all, just to be sure.
    2.) then, i went to the developer options, just to see if anything in there was preventing it. I saw a checkbox for "wireless display notification: show options for wireless display certification." this box was unchecked. i checked it. (my work's wifi requires my phone to accept the certificate. i guess before, this is on by default, but enabling developer options disables it!?!?!?)
    3.) manually went to the work wifi login page (mine is the browser gave me the same error about an unsecured certificate from before when i had kitkat; i proceeded and was able to log in.

    i assume my issue was in the unchecked checkbox in the developer options.... but why the hell would it be default and then magically get unchecked when dev options are turned on!? whatever, problem solved
    07-21-2015 07:02 AM
  11. arunbansal509's Avatar
    Tried cleaning the browser data and checked the developer option box.
    Not able to connect the wiFi at all.
    Says "Authentication Problem"
    Thus cant go on router login page as you mentioned
    07-23-2015 12:38 AM
  12. arunbansal509's Avatar
    tried unplugging and still didn't work.
    I have router username and pwd.
    I can see the config.
    Can you help me.
    08-03-2015 09:43 PM
  13. arunbansal509's Avatar
    can anyone help
    08-12-2015 10:41 PM
  14. arunbansal509's Avatar
    Mr. B. Diddy

    Any update?
    08-12-2015 10:42 PM
  15. arunbansal509's Avatar
    Mr. Nahoku ??
    08-12-2015 10:43 PM
  16. arunbansal509's Avatar
    Mr. Nahoku?
    Any update
    08-12-2015 10:43 PM
  17. nahoku's Avatar
    Sorry, I did try to research this and for sure there are a ton of cases with "authentication error" with android on Google. Most cases are resolved due to wireless encryption type and password. If you haven't solved this yet, you really need to talk to your IT people. There are just too many scenarios and solutions found on the net to try to solve this without having your IT involved. Sorry couldn't be of much help.
    arunbansal509 likes this.
    08-12-2015 11:49 PM
  18. arunbansal509's Avatar
    I'm really fed up looking for solution to this issue.
    Can anyone help please.
    I have router full access and can do changes if required.
    09-06-2015 09:52 PM
  19. andre lemaire's Avatar
    Very helpful. It work s , thank you
    05-16-2016 11:10 AM
  20. andre lemaire's Avatar
    Thanks a lot B. Diddy, it works! Andre
    05-16-2016 11:21 AM
  21. bafuncio's Avatar
    Some sites recommend to restart the router device, and sometime it works.
    Instead of every time restart the router to solve this Android 5.1 Wi-Fi problem, it worked for me:

    Inside the router configuration (e.g., accessing the IP, change the "Group key update" value from 0 to 30 seconds, under the "Wireless > Security" configuration, right below the WPA-PSK/WPA2-PSK item.

    My router model is: TP-LINK TL-WR740N / TL-WR740ND.
    09-14-2016 06:24 PM

Similar Threads

  1. Replies: 2
    Last Post: 11-03-2015, 02:14 AM
  2. Anyone can recommend a Armor Case for my Galaxy S6 Edge?
    By yyy999deba in forum Samsung Galaxy S6 edge
    Replies: 12
    Last Post: 07-17-2015, 09:59 AM
  3. Replies: 0
    Last Post: 07-01-2015, 08:52 PM