1. AC Question's Avatar
    I am using Galaxy Ace GT-S5830I and google play store has stopped working. I am not able to download any application. It shows the error (Error retrieving information from server.[RPC:S-5:AEC-0). My google talk is also not working and it is showing error i.e google authentication failed. Please help
    07-25-2015 12:44 PM
  2. B. Diddy's Avatar
    Does this happen on both wi-fi and mobile data?

    Go to Settings>Apps>All, select Google Play Store, and Clear Cache/Clear Data, then Force Stop. Do the same for Download Manager. Now try again.

    If that doesn't work, then go to Settings>Accounts, remove your Google account completely, then add it back.
    07-26-2015 02:54 AM
  3. junaidkathju's Avatar
    Nothing worked i tried both the options. B.Diddy
    07-26-2015 04:52 AM
  4. B. Diddy's Avatar
    And you tried both wi-fi and mobile data?
    07-26-2015 12:51 PM
  5. Puteri Rinaa's Avatar
    ive tried it and it doesnt work at all. is there any way to solve this problem??
    06-08-2016 08:12 AM
  6. belodion's Avatar
    Try changing the settings diagnostically in Settings, Date & Time. You never know.
    06-08-2016 10:46 AM

Similar Threads

  1. Replies: 3
    Last Post: 07-29-2015, 08:59 AM
  2. How do I download the user guide for my Galaxy S-4?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-25-2015, 04:27 PM
  3. Why is my Galaxy Tab 4 so slow after the update?
    By AC Question in forum Samsung Galaxy Tab4 Series
    Replies: 1
    Last Post: 07-25-2015, 01:22 PM
  4. Any reason to switch from Galaxy S6 Edge to Google Nexus 6?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 07-25-2015, 12:42 PM
  5. Replies: 0
    Last Post: 07-25-2015, 12:38 PM