1. AC Question's Avatar
    Like i mentioned above my Droid Turbo Motorola has been shutting itself off beyond multiple times, This happen when i was at work 11 p.m. On Ifunny just scrolling i stopped to eat my sandwich (since it was break) And my mom shut off, I was unable to turn it back on but realized throughout the night it was "Hot" Active as if it was on, but doing something that wasnt allowing me to Turn it on, It was only later that night 1 a.m. That I was able to turn it on at 2 % battery life, Keep in mind it happened when it had above 50%, It eventually died. I came home plugged it in, Let it charge to 100% and it wont start my phone it does the first two Screens the huge Motorola logo and then the Droid animation logo, After about 10 seconds it just shuts off "Screen Black" I tried clearing the Cache, Tried recovery, and yet nothing. I can't Factory Reset it cause i have important work information. Any help?
    konisencur likes this.
    08-01-2015 07:33 AM
  2. konisencur's Avatar
    I had to make an Account, To add detail to my Problem, yes I am the Guest "AC Question" Above.

    Update - Phone will automatically optimize ("Android is starting... Optimizing app # - 66) Its done this at least 3 times and the 4th it was #67 instead of 66, Quite odd yet no clue. Its been doing this all night and i cant go to bed till i get this solved, Since I have work in about 7 hours. Any help will be greatly Appreciated. I currently have no idea why it says " And my mom shut off" When i typed Phone.. Auto correct perhapes?? No just extremely tired
    08-01-2015 07:42 AM
  3. DwinZly's Avatar
    Did you ever find a fix for this? I am having all of the issues you are describing! Every once in a while the phone will reboot but only for a few seconds then go black again. Can't seem to find anything on the web about it. Any help appreciated!
    10-09-2015 01:01 AM
  4. MrDeathMachine's Avatar
    I am also having this issue.
    03-30-2016 09:50 AM

Similar Threads

  1. Replies: 4
    Last Post: 08-02-2015, 11:32 AM
  2. Replies: 1
    Last Post: 08-02-2015, 02:34 AM
  3. Where is the display input function on my Nexus 10?
    By AC Question in forum Google Nexus 10 Tablet
    Replies: 0
    Last Post: 08-01-2015, 07:29 AM
  4. Replies: 0
    Last Post: 08-01-2015, 07:18 AM
  5. Unmounting USB OTG flashdrive is *also* unmounting micro sd !
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 08-01-2015, 06:55 AM