1. AC Question's Avatar
    (I asked this question previously on Android Enthusiasts, but haven't had an answer in a week.)

    As many of you may know, Nvidia has recalled their Shield Tablets. I'll be getting a replacement soon. I'll be rooting it as soon as possible when I get it, but first I have a few questions.

    First of all, I rooted my tablet using a guide that used Minimal ADB and Fastboot to unlock the bootloader, and flash CWM recovery and SuperSU.

    After rooting I installed Link2SD, pretty much the reason I rooted, to save up some space on my internal memory. Everything was going fine, until I received the recall notice. I moved all my app files back to the internal memory, deleted Link2SD, ran a full unroot on SuperSU, (after a while of hanging on the "Please Wait" screen the app just crashed, it wouldn't load up and Root Checker said I had no root access after rebooting.

    I don't know whether this was supposed to happen or whether it should have gone more smoothly, please give me an answer to this and tell me if it affected my system in any way) and fastboot flashed the stock recovery.img.

    However when I tried to install the update, I got a red triangle error. After checking the log I got an error saying "Package expects build fingerprint of ... or ..., this device has ...."

    I can't remember what the fingerprints were, but the first one was something that began with "nvidia/", had a bunch of numbers in the middle followed by an underscore, then it ended with "/release-keys".

    However the device's current build fingerprint was exactly the same as the first, except that it cut off halfway through, right after the numbers and the underscore.

    I tried resetting my cache, I tried a wipe of the user data. The only way to fix this for me was to re-install a bunch of stock images - recovery.img, boot.img, system.img, etc.

    I don't want to wipe my data next time. So I ask for this in my answer:

    - An explanation of what the error means
    - How this error is caused
    - A way to fix this error without wiping my device
    - How to prevent this error
    - If what happened to SuperSU in my case is normal and if it affected my device in some way
    - And, if possible, a way to install the update successfully without getting this error and without having to unroot or remove CWM, and details on how to do this method and any risks.

    Thanks in advance. An answer soon would be appreciated.
    08-09-2015 03:20 AM
  2. Rukbat's Avatar
    Rooting, even if you unroot, can leave "crumbs" that an update sees and it will refuse to update (beccause you can brick a device if you update it and certain things have been done to it that can only be done if rooted). You have to flash the original ROM. You can't do it without wiping the device, because flashing a ROM gives you an out-of-the-box device.

    You can't prevent it.

    It's normal for most devices. (Some can be updated if you tell SuperSU to prepare for it, but most can't - and it's not Chainfire's fault, it's just that the devices can't do it.
    08-09-2015 06:40 PM

Similar Threads

  1. How to install OF1 update to rooted L720T with TWRP recovery
    By Galane in forum Sprint Samsung Galaxy S4
    Replies: 2
    Last Post: 09-16-2015, 11:57 PM
  2. Why is there no Paperclip icon when using Gmail on my Galaxy S3?
    By AC Question in forum Samsung Galaxy S3
    Replies: 1
    Last Post: 08-17-2015, 09:31 AM
  3. Replies: 5
    Last Post: 08-11-2015, 04:13 AM
  4. Replies: 12
    Last Post: 08-10-2015, 09:36 PM
  5. my GS5 sport will keep turning on
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 08-09-2015, 01:27 AM