1. AC Question's Avatar
    I have an art tablet, its the art trek, model 9020aa with Android version 5.0 and kernel version 3.4.0 and I would like to see if I can get it rooted, I've tried a couple root methods but all have failed.
    08-31-2015 09:32 AM
  2. Cosmic Pie's Avatar
    Which methods did you try?
    08-31-2015 10:03 AM
  3. NLab's Avatar
    Have you try KingRoot? Worked for me on multiple devices.
    08-31-2015 11:32 AM
  4. Eddie Humble's Avatar
    Yes I tried kingroot last night
    08-31-2015 07:43 PM
  5. NLab's Avatar
    I see. Hmm, towelroot is also recommended for this case.
    But I didn't try it myself so can't say much on it.

    Otherwise I would try to root device from computer,
    not sure the correct name for the application, but
    shouldn't be hard to google. It helped me to root
    one of the Mediatek's tablets long time ago.
    09-01-2015 01:41 PM
  6. Eddie Humble's Avatar
    I tried towelroot too and it just tells me my device isn't supported, I found one guide that showed me how to used odin but I am kinda new at this
    09-01-2015 11:06 PM
  7. NLab's Avatar
    Hmm I see. Odin is custom firmware flasher I believe?
    Please let me know how it goes, as I have no experience in using that soft.
    09-03-2015 11:25 AM

Similar Threads

  1. Why has my Facebook check-in feature disappeared?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-18-2015, 01:03 PM
  2. Why won't my wifi turn on after upgrading my S4 to Android 5.0?
    By AC Question in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 09-04-2015, 09:05 AM
  3. The email sync settings in my S6 don't function
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-31-2015, 01:14 PM
  4. Replies: 1
    Last Post: 08-31-2015, 01:05 PM
  5. Why isn't the email sync settings on my S6 functioning?
    By AC Question in forum Samsung Galaxy S6
    Replies: 0
    Last Post: 08-31-2015, 09:06 AM