1. CycloneGU's Avatar
    I noticed two days ago a device claiming to be not recognized every time I loaded my computer. Not thinking anything of it, I decided to just go ahead and ignore it.

    Today, I plugged in my phone today to try to get pictures and video off of it as it claims to be full. And here's where the problem begins; the Unknown Device is apparently my phone.

    Immediate panic set in, obviously, but knowing some things about computers, I did Google research (including here!) and tried some things. I went to the LG site and downloaded (from the Downloads and Manuals section) two files:

    1. LGUnitedMobileDriver_S52MAN314AP22_ML_WHQL_Ver_3.14.1 - This is apparently the driver, which I already had (and have since uninstalled and replaced with an older version, which is also not recognized).

    2. LGMobileSupportTool.exe - The LG Mobile Support Tool.

    I then moved on to Step 3, to plug the phone in and try it in the tool. It was not recognized. I followed their guide to try the driver install, and that failed due to the newer driver. Since then, I've uninstalled and reinstalled and redownloaded things multiple times, and eventually got the older driver in, and even rebooted after all this (I hate rebooting), but nothing is working.

    I need immediate help. I can't get the video and pictures without being able to connect it to the computer. If I didn't use this feature, I would just uninstall the driver and forget about it, but I do use it because it's convenient. I wonder if the problem is actually the computer itself, but other devices (my wireless mouse among them) work just fine, so I think it's specifically a phone driver problem as it's the only problematic item right now. Please help!
    09-04-2015 07:25 PM
  2. srkmagnus's Avatar
    Welcome to Android Central!

    So you have uninstalled and reinstalled the drivers to see if that fixes the problem? Also, try using a different USB port when connecting. If that fails, and you really need to get the pictures off right now, then try another temporary solution:

    Upload to a service such as Google photos, Dropbox, etc. If you don't prefer that, then use a WiFi File Explorer, such as AirDroid, and use that to transfer files without USB - https://play.google.com/store/apps/d...airdroid&hl=en

    Let us know if you have any questions.
    09-04-2015 08:07 PM
  3. CycloneGU's Avatar
    I never considered other upload solutions from the phone. I need to get some videos outta there to make space, so that's the primary concern ATM. I'll look at that for now.

    The bigger problem is figuring out why the driver is not being recognized. It just suddenly went kaput two days ago. I wasn't even charging the phone then. I charged it with the computer off after it happened, so never would have seen the driver issue. I do use the same cable to charge the phone but usually charge when I'm not using the computer now as I seem to have my USB ports starting to not hold devices as well as they used to; even my wireless mouse periodically borks, but only temporarily for a few seconds.

    Speaking of trying another USB port, I did this, and it tried to install the driver (as I did not use it on that port normally), but immediately brought up a second unknown device in the listing. I unplugged and it went away.

    Interestingly, a solution I once used to fix my USB ports not working at all - disabling and reenabling all of the port devices - can't even be done as some now can't be disabled, only uninstalled. Which is weird.
    09-04-2015 08:29 PM
  4. CycloneGU's Avatar
    So...something interesting I just found. There is apparently a software update for the phone itself, for four days ago. From what it seems, the driver might not be updated, or perhaps the software update is supposed to download it automatically. I was never given a notification to the software update (I never have been, I only updated for the first time earlier this year in two or three years), so I'll do an update and see if that helps. I would be baffled, however, if that solves it since the problem is the driver not being a known device, but maybe it was disabled on purpose after a couple of days somehow. That would be kind of a rude way to do it if that's what actually happened.

    I'll try the software update and see what happens.

    EDIT: Turns out I have nothing to update. Hmm.
    09-04-2015 09:45 PM
  5. CycloneGU's Avatar
    srkmagnus: I tried AirDroid. Genius. I hate that you have to use your password again to sign out, but I can deal with it for the small number of times I'll be doing it (eventually will fix the driver, which I still need help with).

    Everything is now safe on the computer and I can start deleting files. Just what I needed.
    09-05-2015 10:53 PM

Similar Threads

  1. Replies: 1
    Last Post: 09-05-2015, 11:11 PM
  2. Replies: 2
    Last Post: 09-04-2015, 11:12 PM
  3. anyone know what this notification is
    By ecksrated in forum Samsung Galaxy S6
    Replies: 1
    Last Post: 09-04-2015, 08:55 PM
  4. Is the Moto X Pure 2015 Qi capable of wireless charging?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-04-2015, 08:25 PM
  5. Replies: 1
    Last Post: 09-04-2015, 08:16 PM