Samsung Galaxy S5 (ATT) won't find Lollipop update. It says my 4.4.4 is latest version.

Printable View