1. obrien_99's Avatar
    So I recently bought a Galaxy S4, and it has Lollipop 5.0.1 on it. Because of the firmware, my battery drains insanely fast, and my WiFi is rendered useless. I have been trying to use Odin to flash KitKat 4.4.2 on my Verizon Galaxy s4 SCH-I545, but it fails every time. I really need help with this... my phone is useless if I can't downgrade it.
    09-13-2015 10:40 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Before trying to address the downgrade issue, maybe we can troubleshoot the battery. Charge up to 100%, then let it drain to 20-30% with normal usage, without charging in between. Then show us:

    1. The main Settings>Battery screen.
    2. The fullscreen battery graph screen (which shows Awake time and Cell Signal Strength).
    3. The Screen category (to see total Screen On time).
    4. The Cell Standby category, if present (to see Time Without Signal).


    Can you give more details about how the wi-fi is useless?
    09-13-2015 10:48 PM
  3. obrien_99's Avatar
    Okay, ill post the pic tomorrow.

    My WiFi is useless because every time I try to turn it on, it won't turn on. If it does manage to turn on, when I try to use it, it will turn off, and I can't turn it back on. I've tried a factory data reset, I've tried pulling my battery many times, and nothing is working. I've read that I need to root my phone to fix it, but I can't root my phone.
    09-13-2015 10:59 PM
  4. B. Diddy's Avatar
    Do you know if the wi-fi was working prior to the Lollipop update? It sounds like you bought it with Lollipop already installed. It's possible it could be a hardware problem, not a firmware one.

    Do you also know if the phone got that Lollipop update as an official over-the-air update? Or did someone flash it manually? If it was done manually, and they flashed the firmware for the wrong model phone, that can cause various things to malfunction.
    09-14-2015 12:04 AM
  5. obrien_99's Avatar
    I believe it had lollipop 5.0 on it when I got it. It then updated to 5.0.1. I bought it from a refurbishing company so I'm not exactly sure. I did do some research though and read that this can be caused because of lollipop. I want to root my phone (it's verizon) but everytime I try it fails. It says to root it and change a file name to fix the wifi but I can't root it.
    09-14-2015 12:09 AM

Similar Threads

  1. My Samsung Galaxy 10 inch tablet won't start. Any tips?
    By AC Question in forum Samsung Galaxy Tab 10-inch
    Replies: 2
    Last Post: 11-06-2015, 07:29 AM
  2. Why won't my phone connect to Android Auto?
    By AC Question in forum Android Auto
    Replies: 1
    Last Post: 09-14-2015, 10:51 AM
  3. Why does my tablet always tell me my WiFi isn't connected?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-13-2015, 10:55 PM
  4. Replies: 1
    Last Post: 09-13-2015, 10:52 PM
  5. I have lost my keyboard
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-13-2015, 10:28 PM