1. AC Question's Avatar
    When I create an event using "OK Google" it creates a calendar event, It's great. One issue - it creates the events in the wrong calendar. I use a non google email address for my default calendar. Google creates the event in my gmail account. When I hand create an event the event gets created in the correct non google calendar.

    How do I get "OK Google" events to be created in the right calendar?
    09-18-2015 10:57 AM
  2. Mark Jordan2's Avatar
    I came to this thread hoping that an answer would be present. I, too, am wondering how to achieve this. Anyone?
    12-15-2015 08:51 AM
  3. rkneeshaw's Avatar
    Same issue here, very irritating!
    12-18-2015 09:50 AM
  4. rob damiani's Avatar
    same issue.
    12-30-2015 07:51 PM
  5. hallux's Avatar
    I believe it's creating the event in the calendar for the account to which you have Google Now linked. If your other account is a Google Apps account (hosted by Google but not a Gmail.com address) you should be able to select that account for Google Now.
    12-30-2015 10:12 PM
  6. geok1's Avatar
    I ran into the same problem earlier today and was able to figure out a solution - if you don't already have the "OK Google" Search widget on your desktop, go ahead and put it there. Then click on the search bar and when that comes up click on the colorful "G" icon on the left, then click on the 3 horizontal bars "menu" icon in the top-left corner, then go to "Settings" -> "Accounts & Privacy", click on "Google Account" and select the account that you want to use as the "Default" for the Calendar.. That should fix it!!!
    02-11-2016 07:53 PM
  7. rkneeshaw's Avatar
    Doesnt work for me, it ONLY shows my google account. not my outlook account.
    02-11-2016 08:08 PM
  8. vaderag's Avatar
    Did anyone get to the bottom of this? I have same issue...
    04-02-2016 07:08 AM
  9. rkneeshaw's Avatar
    Nope, I just don't use "ok google". Cortana worked a lot better. If it wasn't for the app-gap, I'd be back on the windows phone. Such a better OS for productivity
    04-02-2016 09:40 AM
  10. vaderag's Avatar
    Cortana is better in a lot of ways, agreed. I do think OK Google has better voice recognition tho - it rarely hears me wrong - where as Cortana used to get me wrong frequently
    04-02-2016 11:24 AM
  11. thierryEU's Avatar
    I've the same problem. Anyone with a solution? How can I save my event created via "OK Google" in a non Google calendar?
    11-06-2016 06:44 AM
  12. thierryEU's Avatar
    Finally, I decided as workaround to install another assistant app., Indigo. It works with any calendar.
    11-06-2016 07:34 AM
  13. marker227's Avatar
    Has anyone solved this issue? I'm having the same problem.
    11-30-2016 02:41 PM
  14. hallux's Avatar
    Has anyone solved this issue? I'm having the same problem.
    Are both your accounts Google accounts? If so, you need to set which account you have Google Now set up for, then the voice actions will work against that Google account. With a non-Google account, all bets are off, the APIs may not be available to "hook" to the calendar event creation.
    11-30-2016 04:01 PM
  15. marker227's Avatar
    My calendar is from iCloud. I don't use Google Now.
    11-30-2016 04:13 PM
  16. hallux's Avatar
    My calendar is from iCloud. I don't use Google Now.
    "OK Google" is verbal access to Google Now. So, if you use the phrase you use Google Now. The bottom line is - Google Now directly access the data stores for your Google account, it doesn't have that ability with an iCloud account. For instance - I asked for a reminder this morning, that reminder was placed on my calendar as an event.

    How do you connect to the iCloud calendar?
    11-30-2016 05:00 PM
  17. marker227's Avatar
    I use smooth sync for iCloud on Google Play Store.

    When I enter a calendar event manually on the Google Calendar app it works fine.

    It's only Google Voice that gives me an issue.

    S-Voice is adding my events to the correct calendar. Awesome!
    11-30-2016 05:10 PM
  18. Ted Balis's Avatar
    Hi All,
    I had this issue and it drove me nuts. Here's is how to fix it.

    1. Download Cortana and set it up.
    2. Once set up is completed ask cortana to create a calendar event
    3. Cartana will prompt you to choose a calendar - select the calendar you want as your default calendar and select always.
    4. Uninstall Cortana
    5. enable google now and ask google now to create a calendar event. Google now will use the calendar you selected in cortana automatically.

    Hope this helps
    belodion likes this.
    01-05-2018 11:45 AM
  19. jrgreenman1's Avatar
    I can't seem to find any option or check box called "Always" in Cortana. I'm on a Moto Z2 Force with Android 7.1 stock.
    01-12-2018 12:29 AM
  20. Headso's Avatar
    I have a similar problem. Pixel 2 XL

    I am using 2 different gmail accounts, one Personal and the other Work.

    Due to administrator control of my work email i setup a work profile on my phone.
    My issue is that my work calendar is my everything calendar BUT i can't get the Google Assistant to set it as my primary.

    Can't set new calendar event properly. Can't get the proper events to show up on the "Another Widget" widget.

    Any suggestions?
    01-13-2018 12:43 PM
  21. Mitebsyco's Avatar
    I was searching to find out how to get Google assistant to allow me to choose which calendar to add things to since it just adds everything to the default one.
    I have a few shared calendars for friends and family and am often needing to add the events to those calendars so that they can see them.
    With the current setup I have to go to my computer anyway to edit the event to the right calendar.

    Hoping that there is a solution soon since using my watch to add an event block is useless if the right people can't see it.
    05-05-2018 10:12 AM
  22. anon(10471367)'s Avatar
    I was searching to find out how to get Google assistant to allow me to choose which calendar to add things to since it just adds everything to the default one.
    I have a few shared calendars for friends and family and am often needing to add the events to those calendars so that they can see them.
    With the current setup I have to go to my computer anyway to edit the event to the right calendar.

    Hoping that there is a solution soon since using my watch to add an event block is useless if the right people can't see it.
    Install the google calendars app, and after you create an event go to the google calendars app and "copy to" your shared calendars you want.

    It's not great functionality, but it gets the job done. If you're on the default calendars app, you can also just open up the event and edit it which calendar it is in as well.

    I'm surprised google hasn't made this better yet, they're usually ahead of the curve.
    06-06-2018 03:11 PM

Similar Threads

  1. How to pay with card other than the default one?
    By Eric The Duke in forum Android Pay
    Replies: 28
    Last Post: 05-25-2018, 10:40 AM
  2. Carrying note 4 in pocket?
    By quest7 in forum Samsung Galaxy Note 4
    Replies: 19
    Last Post: 09-23-2015, 08:22 PM
  3. I can't add any more songs to Google Play Music playlist?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-18-2015, 10:55 AM
  4. How to prevent calendar notifications on lock screen?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-18-2015, 10:51 AM
  5. my outgoing text messages keep coming back to me in a separate text
    By leslie8671 in forum General Help and How To
    Replies: 0
    Last Post: 09-18-2015, 10:40 AM
LINK TO POST COPIED TO CLIPBOARD