1. AC Question's Avatar
    just updated my motox to android 5.1 now is disconnected from cellular network. i have tried to set cellular network but does not seem to have worked.
    09-18-2015 03:56 PM
  2. belodion's Avatar
    Have you tried a Power Off and Restart?
    Also a Cache Partition wipe?

    Posted via the Android Central App
    09-18-2015 05:50 PM
  3. Mattman555's Avatar
    Sorry to hear this, which moto x gen are your running? Which SIM are you using with your moto x with Straight Talk? Maybe the Verzion SIM?
    09-23-2015 08:19 PM

Similar Threads

  1. How to get battery percentage next to battery icon?
    By zrxoa1 in forum Moto G (2015)
    Replies: 6
    Last Post: 09-25-2015, 02:21 AM
  2. Replies: 4
    Last Post: 09-22-2015, 06:51 PM
  3. Replies: 1
    Last Post: 09-19-2015, 12:52 AM
  4. "App blocking access to keyboard" error message.
    By gmermel in forum General Help and How To
    Replies: 0
    Last Post: 09-18-2015, 03:14 PM
  5. All apps stop after bad root
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 09-18-2015, 03:14 PM