1. AC Question's Avatar
    My new (two weeks) S2 will not recognize the 128Gb MicroSD card I bought for it. It doesn't recognize the 32Gb MicroSD card I took out of my S5 to check either. Using a card reader my W10 PC does recognize the card and I was able to copy a file to it. The S2 does not recognize the card and I have tried several re-starts.
    Any suggestions? Is there an install routine? I don't think so.
    BTW, I really don't like the silly tool you have to use to get the slot open.
    09-20-2015 05:46 PM
  2. Teejai80's Avatar
    09-20-2015 08:16 PM
  3. OsoMalo's Avatar
    Yes, the card is installed correctly.
    I cannot reformat the card in the S2 as it does not recognize it all. The S2 did not recognize the MicroSD card I took out of my S5 phone for a test either.
    When I loaded it into my PC using a USB card reader I believe the format was exFAT. I was able to add a file (photo) to the card OK, so the card itself seems OK, it is the S2 that seems to have a problem reading or even detecting the card(s).
    09-20-2015 09:52 PM
  4. OsoMalo's Avatar
    SOLUTION
    Problem fixed by formatting card using the SD Association formatting tool.
    Why this worked is beyond me. The card (PNY) was brand new, already formatted exFAT and was visible to my W10 PC. There must be some subtle difference between the O/S formats.
    Long story short, now all is good.
    Teejai80 likes this.
    09-21-2015 09:31 PM
  5. Teejai80's Avatar
    Awsome well done!

    Sent from my XT1562 using Tapatalk
    09-22-2015 01:16 AM

Similar Threads

  1. How to Stop Apps from Storing Data to SD Card
    By AC Question in forum Ask a Question
    Replies: 4
    Last Post: 06-10-2018, 11:06 AM
  2. How do I transfer bookmarks from my Galaxy 3 to Note Edge?
    By AC Question in forum Samsung Galaxy Note Edge
    Replies: 1
    Last Post: 10-07-2015, 09:33 PM
  3. Replies: 1
    Last Post: 09-20-2015, 10:40 PM
  4. Replies: 0
    Last Post: 09-20-2015, 04:48 PM
LINK TO POST COPIED TO CLIPBOARD