1. AC Question's Avatar
    I have smartphone Android Jelly Bean. My phone has been TOTALLY messed up recently due the "Time Service" and "MonkeyTest"--super annoying! - And just yesterday "Android System" had been popping up on my screen NON-STOP! (I think my phone's gonna die soon~ :/)
    Well anyway, I have reset my phone (of course I have backed up my apps.) When I tried to restore them, some have been restored and some couldn't be installed, and I don't know why. I tried downloading them from Google play but it can't!!! And it keeps on saying " Can't intall App --- (error code -24)

    Could someone please help me with this ?
    Please don't say my phone's at its END!!
    Any Help would be very much appreciated! Thank You
    09-22-2015 08:15 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Does this happen on both wi-fi and mobile data?

    Try going to Settings>Apps>All, select Google Play Store, and Clear Cache/Clear Data, then Force Stop. Do the same for Download Manager. Now try again.

    If that doesn't work, try going to Settings>Accounts-Google, select your Google account, and remove it completely from the phone. Then add it back again, and see if that helps.
    09-22-2015 09:53 PM

Similar Threads

  1. Replies: 18
    Last Post: 11-07-2015, 06:14 PM
  2. Replies: 1
    Last Post: 09-22-2015, 09:54 PM
  3. Replies: 2
    Last Post: 09-22-2015, 06:21 PM
  4. Why is Google search saying it stopped on my straighttalk phone?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 09-22-2015, 05:08 PM
  5. Google play store
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-22-2015, 04:59 PM