1. AC Question's Avatar
    Hi,
    My motog 1st gen fell into the toilet day before yesterday. I took it out within 10 seconds I guess. Tried to switch it off, but it was stuck in the boot up loop and didn't switch off. So I tried using a dryer to absorb all the moisture first and then put it in a airtight bag full of rice and waited for the battery to drain for the phone to shut down. It laid there for 30 hours like that.
    After that I tried charging it and checking if it works but its still in bootloop.

    Please suggest what to do.
    09-24-2015 07:25 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Sorry, it's most likely shot. You can review this guide: http://forums.androidcentral.com/amb...e-got-wet.html
    09-24-2015 02:27 PM

Similar Threads

  1. S5 is unable to record video in UHD (4K)
    By micksul1 in forum Samsung Galaxy S5
    Replies: 4
    Last Post: 11-15-2015, 12:39 PM
  2. Replies: 1
    Last Post: 09-24-2015, 02:36 PM
  3. If cloud shows up in the gallery does that mean something is saved there?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 09-24-2015, 02:30 PM
  4. Replies: 1
    Last Post: 09-24-2015, 09:09 AM
  5. Issues With The LG G2 (Battery)
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-24-2015, 07:41 AM
LINK TO POST COPIED TO CLIPBOARD