1. Catwoman1199's Avatar
    I just got this phone yesterday and I didn't drop it or anything like that.
    Every time I open the google play store the app says it gets a connection time out, it says this for almost every page I open in the app. So I went to, "my apps>all," in the google play store and that was the only page that loaded. So I go to download Dropbox app because I need it for school. It starts downloading. It's been over 10 hours since I started that download. It got stuck at 66% done. I'd tried to download other apps too And got the same result. No error messages, they'd just get stuck. I could look up apps in the search bar but I couldn't download them either. Aside from going to, "my apps>all," and searching in the search bar, every page I went on lead to a loading symbol and then eventually to,"connection time out, retry."

    I looked up this issue and found this website. There was another forum question and someone said to go to the phones Settings>apps>all, find google play store and then clear its cache/data. Then force stop it. So I did that in hopes of it working but now, the pop-up that comes up after you click, "install," on the google play stores apps, doesn't load and also says, "connection time out."

    So I decided not to duo the other thing the person said on the forum, which was to delete my google account from my phone and re add it, until I get the thumbs up from someone I here directly.

    I also updated my phone as 3:01pm, and that didn't change anything either. There was no problem updating my phone.

    What do I do? This phone is supposed to be fast with it's, "quad core," but its not! What's going on?!
    09-24-2015 02:50 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! That guy was probably me. This is usually what I suggest:

    "Does this happen on both wi-fi and mobile data?

    Try going to Settings>Apps>All, select Google Play Store, and Clear Cache/Clear Data, then Force Stop. Do the same for Download Manager. Now try again.

    If that doesn't work, try going to Settings>Accounts-Google, select your Google account, and remove it completely from the phone. Then add it back again, and see if that helps."

    So for you, it's important to know if this is happening on both wi-fi and mobile data. It's also important to know if you tried clearing the cache and data from the Download Manager.

    Removing your Google account and adding it back isn't a big deal. The next step might be a factory reset, which is a bigger deal, but at least your phone is pretty new, so presumably you haven't accumulated a lot of personal data on the phone yet.
    09-24-2015 05:22 PM
  3. Aazay lama's Avatar
    its very simple bro i was facing the same proble a couple of minits before and what i did was just
    go to play store and then setting and press the build version and it willl automatically do the thing it will ask to download new version of play store try it itlll work
    11-14-2015 01:28 PM
  4. debneeley's Avatar
    I did the android update on my stylo, now I get this message flashing on screen " unfortunately Google play store has stopped working". I cleared the cache etc. Still flashing!! Any idea how to fix this?
    03-15-2016 10:53 AM

Similar Threads

  1. What is the best distribution to begin with Linux ?
    By BearDroidGames in forum Linux
    Replies: 9
    Last Post: 01-29-2020, 04:23 PM
  2. Replies: 22
    Last Post: 06-23-2017, 09:32 PM
  3. Note 2 Dies When Unplugged from Chager.. HELP!
    By dodong27 in forum AT&T Galaxy Note 2
    Replies: 4
    Last Post: 12-31-2015, 04:50 PM
  4. Why wont my Samsung S3 mini screen turn on?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 11-14-2015, 01:30 PM
  5. Replies: 1
    Last Post: 09-24-2015, 05:29 PM