1. AC Question's Avatar
    Hi, Just had my phone repaired under warranty for a main board fault, and came back factory reset. Now i am unable to upgrade from Kit Kat to Lollipop (which i had installed before phone broke). When i press the 'Check now for update' button, it says checking, and then comes up with a prompt saying 'Your phone is not registered yet.' Only gives me a single option after this, an 'OK' button.
    Already called LG Care twice today, first time she asked me to factory reset again and make sure i dont skip any of the T's & C's, which i did, and still no luck. Then second person got me to download LG Mobile Support Tool, which told me I was on the latest version available for the device through the mobile support tool.
    Also tried registering my product on LG's website, which has had no effect on the issue either.
    Please help me out here guys, I don't know what to do and i miss Lollipop.....
    09-28-2015 08:52 PM

Similar Threads

  1. Widgets Freezing - Not Updating
    By asiano in forum Google Nexus 6
    Replies: 4
    Last Post: 09-29-2015, 10:08 AM
  2. Why can't I view a PDF file from download history?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 09-28-2015, 11:08 PM
  3. Replies: 1
    Last Post: 09-28-2015, 10:22 PM
  4. Is there an LG G3 camera module replacement?
    By AC Question in forum LG G3
    Replies: 1
    Last Post: 09-28-2015, 09:44 PM
  5. FB not syncing after a factory reset
    By Marcus Sherwood in forum Samsung Galaxy S6 edge
    Replies: 1
    Last Post: 09-28-2015, 08:48 PM