1. AC Question's Avatar
    I have a Verizon Galaxy S3. Bought it last year on eBay. It was running fine till 3 days ago. Then when I disconnect the charge cable. It won't turn on at all (no vibration, no display). If the charge cable is connected, the screen shows battery being charge. However, unlike before, no percentage shown till it's 100% charged. If I press the Power button, it will show Samsung logo and then Verizon logo, then it just goes back to battery charging display.

    I tried removing the battery, waited and then pressed the Power button. After re-inserting the battery, pressed the Powe button. The phone showed no response (no vibration, blank screen). The condition stays the same as above.

    I put the battery into another S3 and verified the battery is good.

    I found your suggestions. With the charge cable connected and pressing Power/VolumeUp/Home button, I went into Recovery mode. I tried Wipe Cache from Partition. No improvement. I tried Factory Reset. No improvement. Then I pressed Power/VolumeDown/Home button. In the Download mode, I used Kies to re-install the firmware. After it went through the whole process, it is in the same condition as it had started.

    What else can I do?
    10-12-2015 06:18 PM

Similar Threads

  1. Replies: 28
    Last Post: 11-10-2015, 09:37 AM
  2. A Convenient Surprise On My Moto X
    By izzy67 in forum Moto X (2014)
    Replies: 4
    Last Post: 10-26-2015, 10:04 PM
  3. Replies: 2
    Last Post: 10-13-2015, 06:14 PM
  4. My galaxy tab 3 power button an smart case don't work!
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 10-12-2015, 06:03 PM
  5. Screenshot not working on Moto G?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 10-12-2015, 04:58 PM