1. dstracke's Avatar
    I have a Droid phone and I have tried installing directly from the link and from Google Play Store. The apps start to install but never complete the install process.
    10-13-2015 12:39 PM
  2. SpookDroid's Avatar
    Have you tried uninstalling updates first? If you go to the App Manager in your phone and find the Drive app, there should be an option to either uninstall the app or uninstall updates. Try doing that, reboot, and then try to re-install/re-update and see if it works.

    You can also try to clear the Play Store's Cache first from the App Manager as well.
    10-13-2015 12:49 PM

Similar Threads

  1. Replies: 1
    Last Post: 10-13-2015, 07:07 PM
  2. Replies: 1
    Last Post: 10-13-2015, 07:06 PM
  3. Is the Moto X second generation still viable?
    By cardsfanbj in forum Ask a Question
    Replies: 2
    Last Post: 10-13-2015, 01:26 PM
  4. Can I use a sim card purchased in Ireland in my Galaxy S6?
    By AC Question in forum Samsung Galaxy S6
    Replies: 1
    Last Post: 10-13-2015, 12:52 PM
  5. Replies: 1
    Last Post: 10-13-2015, 12:44 PM