1. AC Question's Avatar
    Ok so i bought a note 3 online and it was loosing charge very fast but then I loaded 4.4.4 on it and now that seems solved HOWEVER, I can't get it to charge. It shows the icon that says its charging but when I walk away and check on it again later the battery has gone down from "63% to 60%". In other words Its showing that it is charging but it is not its not even stabilizing the battery at its current charge. anyone know whats going on? I'm thinking it is the charger port inside the phone I have tried another charger on it that DOES work with my galaxy s4 perfectly. but with my note 3 it just has no effect. So i can rule out charger and if i rig my battery into my s4 with a rubber band it will charge the battery so I can also rule out my battery i believe. So, what do you guys think?
    10-18-2015 10:52 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! I agree, it might be the microUSB port. When the phone is charging on a wall outlet, does it say "Charging (AC)" or "Charging (USB)"?
    10-18-2015 02:38 PM

Similar Threads

  1. Nexus 7 On/off button not working!
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-18-2015, 02:51 PM
  2. How can I remove 360 security from my HTC phone?
    By AC Question in forum HTC Desire 820
    Replies: 1
    Last Post: 10-18-2015, 02:42 PM
  3. Clean IMEI, but...
    By MizWylie in forum Ask a Question
    Replies: 1
    Last Post: 10-18-2015, 11:06 AM
  4. Replies: 0
    Last Post: 10-18-2015, 09:47 AM