1. AC Question's Avatar
    Like most I have been receiving the "Error retrieving information from server. [RPC:S-7:AEC-0]" every time I try to download an app from the Play Store. My phone had been doing that previously so I had it reset to its factory setting from when I first had it. I still get the Error message and there is no data to clear from the app store so it won't let me. What do I do?
    10-25-2015 12:20 AM
  2. GHaustin's Avatar
    “””” A Fix For Not Being Able To Download Or Install Apps From The Google Play Store
    For People Who Have Tried EVERYTHING And It Still Doesn’t Work !!!!!!”””””””””

    To keep a long story short, I had decided to start using an older Android phone of\my wife’s. So I decided to factory reset it so I could start fresh on it. Well after it restarted it immediately began to ***** about not being able to connect to server. Then when I opened the play store everything I tried to download was Error retrieving information from server. I tried everything I could think of but nothing worked. Then hitting the forums and trying everything listed in them at least 10 times. So I was about to just give up then my little voice said try this one last thing and to my surprise it WORKED. Everything was working, updating and downloading. Here are the step to what I did.
    1. Remove all accounts and yes this means do a factory reset
    2. Restart the device
    3. After start up DO NOT and I mean DO NOT create, link or sign in using your google account info. Hit skip this step and let the device fully start up.
    4. After is has started and you have a data connection open the Play Store
    5. At this time NOW sign in with your google account info.
    6. Just sit back and enjoy watching the updates come zooming in.
    I don’t know why this worked or how but it worked. I am posting this so that others who are as frustrated as I was, might have a chance at PEACE. May this post save others and lead to calm.
    11-12-2015 06:52 PM

Similar Threads

  1. Why is the status bar going nuts?
    By AC Question in forum Ask a Question
    Replies: 5
    Last Post: 10-26-2015, 05:54 PM
  2. Is there testing for problems to get soluy?
    By AC Question in forum Samsung Galaxy S5
    Replies: 0
    Last Post: 10-25-2015, 12:18 AM
  3. How can i resize my accuweather widget
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 10-24-2015, 11:59 PM
  4. My S3 screen is not working.
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 10-24-2015, 11:56 PM
  5. I have a portable hotspot from T-Mobile how do I use it?
    By AC Question in forum General Help and How To
    Replies: 0
    Last Post: 10-24-2015, 11:49 PM