1. AC Question's Avatar
    I have noticed this with the new android 6.0 marshmallow update. Wifi turning off despite "keep wifi on during sleep" set to "always" on Nexus 5 phone. When I power on the phone I see it quickly re-connect WiFi. But why isn't it already on? I've also noticed that my apps are not syncing very often when the phone is left in sleep.

    Anybody else seeing this behaviour? I'm all for battery savings, but if it's plugged into power & WiFi is available, why is it not just keeping it on??

    Settings:
    "keep wifi on during sleep" set to "always"
    settings-->location-->menu-->scanning -> set to "Wi-Fi scanning"
    Battery-->Battery saver--> Off
    10-25-2015 09:20 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Try going to Settings>Battery, tap Menu>Battery Optimization, choose the apps that you don't want to Doze, and tap Don't Optimize. Does that make a difference?
    10-25-2015 10:25 PM
  3. soosgyul's Avatar
    I do have this problem. Turning off the battery optimisation seems logical, however I have no idea what app I actually need to not turn off the wi-fi.
    10-26-2015 02:27 PM
  4. Tex99's Avatar
    By default it optimizes everything but "Google Play Services". I additionally added to the "not optimized" category: "Android System", "Calendar", "Calendar Storage", "Gmail" and "Google Contacts Sync".

    This seems to have worked mostly. There is the odd time WiFi is off when plugged in but it is often on and email seems to come through relatively quickly when it is charging.
    10-27-2015 11:09 AM
  5. sierratango's Avatar
    Any updates on this issue? I've also been facing this problem since 6.0 and haven't found a solution or workaround yet.

    This is clearly a bug since it goes against what the system has been set to do so I think this should be reported to the android bug tracker to get it properly fixed.
    11-29-2015 01:54 AM
  6. soosgyul's Avatar
    no, it's still not working properly.
    12-22-2015 09:36 AM
  7. Wendy Macinskas's Avatar
    I checked the settings. They are set to "always". Why does my device turn off things. I have a Nexus 7, first generation 5.1.1 running Lollipop.

    Thanks for your answer.
    05-15-2016 11:46 AM
  8. jjcoolaus's Avatar
    I have FINALLY found a wifi keep alive app that works very well with Marshmallow:
    Free: https://play.google.com/store/apps/d...fikeeper&hl=en
    Pro ($1): https://play.google.com/store/apps/d...eper.pro&hl=en

    They updated it to add marshmallow support and it really does support it in that my wifi stays on, even if the connection is idle, all day at work now. Which is great because my VPN stays connected as well, which is what I really wanted.

    I don't like how marshmallow jumps on LTE when wifi is disabled. After using up over 3GB in a week like that, I got into the habit of disabling mobile data when i get to work, and enabling it when i goto lunch and disabling it again when i get back and now I don't have to.

    Awesome little app, recommended. Unless battery life is critical for you – but at work my phone is often on charge anyway.

    I also like wifi keepalive (https://play.google.com/store/apps/d...imonitor&hl=en) but best wifi keeper is a bit better. I found wifi keepalive had lots of errors if connected to a VPN.
    05-26-2016 02:48 AM
  9. Brandi Raggio's Avatar
    I have the same problem, and it pisses me off, as I don't have unlimited data!
    07-17-2016 11:27 PM
  10. speck-1234's Avatar
    I had the same problem with my Samsung Galaxy S3 SGH-T999L from T-mobile.
    I rooted it with Kingo ROOT. I tried every app including Wifi Keep Alive, even tried apps that require root, still turns off on sleep.
    It seems to still obey the wifi sleep policy even when plugged in.
    07-23-2016 04:04 PM
  11. laraxpng's Avatar
    Still no solution? Does anyone know is it a Android 6 bug or something about hardware of different phones? It is really frustrating!!! After 2-3 mins wi-fi goes turn off...
    09-16-2016 06:13 AM
  12. laraxpng's Avatar
    "I have FINALLY found a wifi keep alive app that works very well with Marshmallow:
    Free: https://play.google.com/store/apps/d...fikeeper&hl=en"

    doesn't work!
    09-23-2016 05:30 AM
  13. Geschichteff's Avatar
    I have FINALLY found a wifi keep alive app that works very well with Marshmallow:
    Free: https://play.google.com/store/apps/d...fikeeper&hl=en
    Thanks!

    doesn't work!
    Disabling battery optimization for this app may help
    09-23-2016 01:45 PM
  14. laraxpng's Avatar
    Disabling battery optimization for this app may help
    No, I tried everything.
    It's weird that wifi behave "normal" on some networks, and on some other doesn't??!
    09-24-2016 01:29 AM
  15. john2341234's Avatar
    Anybody found a solution to this? This is ridiculous this bug haven't been fixed yet! I have got HTC One S and Android 4.1.1. and tried everything mentioned above except the apps that suppose to keep wi-fi alive, I''ll try them next.
    10-30-2016 02:57 PM
  16. natezimmer's Avatar
    Still looking for a solution, its a major PIA. Nexus 6 here. 12/9/16.
    My issue is i'm trying to use it for IoT application but the phone keeps dropping from the network cuz the wifi shuts off nomatter what you set it to, no matter what wifi keep alive apps you have. Its something in the underlying OS that simply ignores any and all attempts to keep the wifi active. ;( Only way to fix is to unlock the phone which breaks its usability in many ways.
    12-09-2016 10:47 AM
  17. Prajay Potnis's Avatar
    Still no solution? Does anyone know is it a Android 6 bug or something about hardware of different phones? It is really frustrating!!! After 2-3 mins wi-fi goes turn off...
    U just need to check the battery saver app u have on ur andriod. Uninstall any such app and u will see the results
    12-20-2016 09:13 AM
  18. Rgilkes's Avatar
    The following worked for me on my Nexus 5.

    Just toggle the "Keep Wi-Fi on during sleep" setting:

    * Go to Settings > Wi-Fi
    * Tap the ellipsis at top-right to access the Wi-Fi menu and then tap Advanced
    * You will notice "Keep Wi-Fi on during sleep" and it may be set to "Always"
    * Tap it and switch to "Never" then back out to ensure that setting takes effect.
    * Tap "Keep Wi-Fi on during sleep" again and set it to "Always"
    * Back out again

    This solved my problem.
    03-05-2017 07:34 AM
  19. Kami Kazi's Avatar
    Still not working I have Nexus 5
    09-25-2017 09:22 PM
  20. belodion's Avatar
    [See also here, regarding above poster’s question:]

    https://forums.androidcentral.com/go...i-problem.html
    09-26-2017 06:19 AM
  21. Kouuf's Avatar
    If you haven't already found a solution, restarting my phone worked for me. I have a galaxy j5 prime with android marshmallow and it worked miraculously.
    10-13-2017 12:15 AM

Similar Threads

  1. Google "Navigate to [location]" and Waze integration?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 11-25-2015, 06:19 PM
  2. Replies: 2
    Last Post: 10-25-2015, 09:52 AM
  3. * Move micro SD card from S2 to S5?
    By theboxer5 in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 10-25-2015, 09:42 AM
  4. How to change country
    By pmo972 in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 10-25-2015, 09:22 AM
  5. Files not showing up on ADB for Galaxy S3
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 10-25-2015, 09:16 AM
LINK TO POST COPIED TO CLIPBOARD