1. jwells1964's Avatar
    I have a BLU Studio 5.5c running the stock Kitkat 4.4.2 ROM that just refused to turn on one day and has been stuck in boot loop for about 8 days, these are the steps I have all ready taken that have failed.

    1) boot device into recovery and "wipe cash" then "wipe data/factory reset" then reboot system, this has no effect at all.

    2) Installed ADB Universal Drivers and SP Flash Tool both ver. 3.1 and 5.0. Once I had communication with the SP Flash Tool, i found the stock ROM with a scatter file for use with the SP Flash Tool at the Need Rom website <MT6582_BLU_d690_BLU STUDIO 5.5 C_4.4.2_ALPS.KK1.MPI.V2.10.zip> I started with the new version of SP Flash Tool 5.0 and I loaded the scatter file found in the unpacked ROM file into the flash tool and started a FORMAT using the Automatic setting then with the battery removed I connected the phone USB cable to my PC and it started the process and completed successfully. Next I disconnected the phone from the PC and in the SP Flash I selected DOWNLOAD and then connected the phone to the PC and the download started and completed without errors. I then tried to reboot the phone and still boot loop no change, I am going to speed things up here, I tried both flash tools, using every available command and sequence, almost every time I ran the program it was a successful load but no change to the phone. I also tried flashing the phone then booting into recovery and running a "wipe data/factory reset" no change.

    2) In recovery I have also tried "apply update from ADB" using this I was able to start the file transfer "adb sideload <file name.zip>" with the following files and results.

    a: BLU_d690u_STUDIO-5.5-C_4.4.2.zip ...File will start to transfer and will reach 76% and then stop and hang indefinitely then give a "fail to read" error.

    b: kitkat-4.4.4-FULL.zip... this file will sideload to 100% then the android stands up and then falls down and the upgrade is aborted.

    c: KitKat update files for 4.4.2.zip loads all the way then makes it about 50% thru the update then the android falls and it is aborted
    Kitkat update files for 4.4.2 to 4.4.3 same outcome and update files for 4.4.3 to 4.4.4 same. I have tried countless other files ADB Sideload and SP FLash no change.

    In recovery I have also tried to "update from sdcard" and I load the zip onto my sd card using my PC then I insert the sd into phone and boot recovery then I choose "update from sdcard" and i navigate thru the file tree never finding the .zip file I loaded because it is only recognizing the internal storage as sdcard 0 and never sees the external sdcard 1. I have also tried to "update from cache" never finding a recovery option. can someone help me find the correct update or rom and explain a way to put the file in the correct directory so I can restore this POS!
    Gilot likes this.
    10-31-2015 04:36 PM
  2. uncps's Avatar
    I have the same phone same problem, I can't seem to find the MT6582_BLU_d690_BLU STUDIO 5.5 C_4.4.2_ALPS.KK1.MPI.V2.10.zip file to even try what you have done.
    could you post a link to the file please?
    thanks in advance
    04-13-2016 03:19 AM
  3. rosel11078's Avatar
    I have the same situation with this phone, I used every SP Flash tool option to flash everything finish ok but the phone kepp in boot loop
    02-13-2017 09:15 AM
  4. uncps's Avatar
    Try here for the correct file for your blu phone

    It has been a while since I got mine fixed for the second time. seems to me that the problem occurs when the phone is loaded with to many app's and memory is low. once fixed I suggest rebooting at least once a weak, and if the phone seams to be hanging reboot and uninstall seldom used programs. set every program you can to use (move to) sd card. good luck I rem it was a challange but keep at it and scoure the web for info on it. looks like my sp flash tool is v5.13.52.200.
    02-13-2017 11:17 AM
  5. rosel11078's Avatar
    My phone is Blu Studio 5.5c D690u and I can't see it here
    02-14-2017 03:28 PM
  6. uncps's Avatar
    click on-BLU Studio 5.5s (D630)
    try the d630 generic file
    when you click it it will be added to dl que and it will start down loading when it is ready

    if that is not working for you try the 5.0c files
    02-14-2017 03:59 PM
  7. rosel11078's Avatar
    hey my friend maybe the phone deep break with that
    I will try first with this: MT6582__BLU_D690u__BLU_STUDIO_5.5_C__4.4.2__ALPS.KK1_.MP1_.V2.10
    if isn't work I'll try what you say
    02-14-2017 04:10 PM
  8. rosel11078's Avatar
    Hey friend my Blu is back to live now with link I posted before, so I have tried everything and nathing work before how jwells1964 said
    but now is amasing faster, is somebody have trouble with this phone (Blu Studio 5.5c D690u) now don't need to worry, just:
    1- Search and download SP_Flash_Tool_v5.1628
    2- Download flash mediafire link posted before
    3- Unzipped and use MT6582_Android_scatter.txt
    4- Click in Download button and wait to green finish.
    02-15-2017 09:24 AM
  9. uncps's Avatar
    congratulations and good job finding that file.
    02-15-2017 04:43 PM

Similar Threads

  1. Text messages stuck at "sending"
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 01-24-2016, 11:49 AM
  2. Replies: 6
    Last Post: 11-13-2015, 03:53 PM
  3. How do u slow the animations for games down
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-31-2015, 05:17 PM
  4. Replies: 1
    Last Post: 10-31-2015, 04:58 PM
  5. Battery barely lasts 10 hours in standby ???
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 10-31-2015, 03:08 PM