1. AC Question's Avatar
    Current situation:
    My phone turns on, for some time it shows a black screen with word HTC in the middle, then it shows the bootloader page. But there is no option such as recovery, fastboot, etc. Please see the screen shot here: http ://i65.tinypic. com /28ica39.jpg (remove spaces, sorry I cannot post links in the forum yet)
    the vol.up and down keys do nothing. Selecting RUU with power button does nothing. I can push and hold power button to shut down.

    Is it bricked?!!! :-s

    What happened:
    I have(had?!) an HTC One M7, s-on, rooted, stock-rom, TWRP recovery, hboot 1.61.0000.
    I was trying to un-root my phone, I did the followings:
    1. Booted into bootloader, fast boot and run "fastboot oem lock"
    It worked fine, phone restarted in the bootloader and it said "re-blocked"
    2.I ran the command "fastboot oem rebootRUU "
    It took some time, but eventually, the phone restarted automatically.

    since then I am stuck in that screen (see the screenshot above)

    3. when I run the command "fastboot flash zip firmware.zip", I get the following result in the command terminal:

    target reported max download size of 1514139648 bytes
    sending 'zip' (44368 KB)...
    OKAY [ 2.737s]
    writing 'zip'...
    (bootloader) adopting the signature contained in this image...
    (bootloader) signature checking...
    (bootloader) zip header checking...
    (bootloader) zip info parsing...
    (bootloader) checking model ID...
    (bootloader) checking custom ID...
    (bootloader) checking main version...
    FAILED (remote: 43 main version check fail)
    finished. total time: 8.585s

    and in the phone screen it says:
    "Main version is older!
    Update Fail"

    the Firmware.zip that I am trying to flash is the one I extracted from the latest OTA that I received from the carrier.

    What should I do? Is it a (easy) solution to get over this and unroot my phone?
    if no, I just want to forget about unrooting, and get back to normal! Have my phone working!

    any help is highly appreciated.
    11-07-2015 05:28 AM
  2. geek654's Avatar
    [solved] almost!

    Good news: It was not bricked
    Bad news: I could not unroot yet.

    So, after several attempts I could fastboot and unlock the phone again. Have TWRP recovery running, and the phone is back to normal (rooted and working)

    The question is how to unroot a S-on, hboot 1.61 HTC One M7 ?
    11-07-2015 07:19 AM
  3. ChristianNeedshelp's Avatar
    How exactly did you solve the issue? i am having the same issue
    02-15-2016 06:54 PM

Similar Threads

  1. Replies: 1
    Last Post: 11-07-2015, 07:57 AM
  2. Replies: 1
    Last Post: 11-07-2015, 05:45 AM
  3. In need of help Please!! Jellybean 4.2.2
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 11-07-2015, 05:10 AM
  4. Replies: 0
    Last Post: 11-07-2015, 03:46 AM
  5. My htc one max just deleted everything
    By Dogfish666 in forum HTC One Max
    Replies: 0
    Last Post: 11-07-2015, 03:40 AM