1. AC Question's Avatar
    My device has 16 GB storage, ~4 GB of internal storage (/data) and ~10 GB of phone storage (/storage/sdcard0, FAT) and is rooted. I am still stuck at Android 4.4.2 because I have a MediaTek device (MT6592). You ask me why I have more internal storage than usual? Well, I modified EBR1&EBR2 to get more /data. It worked fine.

    I had WhatsApp installed on my internal storage (not SD Card) but for a few days already WhatsApp disappears after rebooting. If I go to Settings -> Apps, I can see that com.whatsapp is there but it is only about 72 KB in size and has no data. Looking into /data/app and /data/data tells everything: WhatsApp IS installed but somehow not "visible" or some way corrupted. So, I opened up Terminal Emulator and copied the data to external sd card (/storage/sdcard1), then I uninstalled it using package manager and installed it again (using package manager) on internal storage. After that I copied the data back I set correct owner (u0_a124) and permissions recursively (0755) and WhatsApp worked again perfectly fine.
    After a reboot whatsapp disappears again and I have to do everything again.

    So I installed GBWhatsApp which has another package name (com.gbwhatsapp), therefore it is another app and has nothin to do with normal WhatsApp (com.whatsapp).

    Unfortunately, after a reboot, the same happens to GBWhatsApp.
    This is very strange and creepy and I don't know what to do.

    All apps are working fine, except WhatsApp.

    Now, I created a second partition as ext4 on my external SD card and moved data & app to it, symlinked to /data/app and /data/data and corrected all permissions.

    Now it is working again perfectly fine.
    Not sure if it keeps until reboot but I have to know what to do now!

    I don't want to do a factory reset because backing up and restoring using recovery is a big mess, and it is too much work.

    Help me out please.
    11-07-2015 09:01 AM
  2. xdevs23's Avatar
    Sorry, I posted it as guest, I am the thread creator.
    11-07-2015 09:03 AM

Similar Threads

  1. Replies: 1
    Last Post: 11-07-2015, 09:08 AM
  2. Replies: 0
    Last Post: 11-07-2015, 07:55 AM
  3. Replies: 0
    Last Post: 11-07-2015, 07:46 AM
  4. Replies: 0
    Last Post: 11-07-2015, 06:01 AM
  5. Why can't my video streaming be played after some Android updates?
    By AC Question in forum General Help and How To
    Replies: 0
    Last Post: 11-07-2015, 05:37 AM