1. AC Question's Avatar
    This is a new replacement phone I just turned on about a month ago. It normally works fine, hardly had any problems and was very careful to avoid downloading or entering anything suspicious. I have 360 Security and Anti-Virus Booster & Cleaner stored on it and I daily clean my phone. All my music and pictures are kept on my SD card.

    About 10 hours ago, my dog knocked my phone off a table onto the rug. No physical damage. However I can't keep my phone functioning and keep getting "_____ has stopped working" signs. This happens for every app I open. Once I select either Wait or Close, the entire phone freezes and won't work anymore. The time between my phone working and receiving the "stopped working" sign varies from 10 seconds to 2 minutes each time. If I lock the screen, it won't turn back on.

    The only way I can get it to run again is if I restart it, but only for a short amount of time before seeing the error again. I've already emptied the cache from my launcher in Apps and ran every test I could on my phone but no luck.

    I could try emptying the launcher's cache data but it sounds risky and may not work.

    Do you know what I should do? Please help me, my family is relying on me and I need a phone to communicate with them.
    11-16-2015 02:15 AM
  2. itguyjax8430's Avatar
    This is a new replacement phone I just turned on about a month ago. It normally works fine, hardly had any problems and was very careful to avoid downloading or entering anything suspicious. I have 360 Security and Anti-Virus Booster & Cleaner stored on it and I daily clean my phone. All my music and pictures are kept on my SD card.

    About 10 hours ago, my dog knocked my phone off a table onto the rug. No physical damage. However I can't keep my phone functioning and keep getting "_____ has stopped working" signs. This happens for every app I open. Once I select either Wait or Close, the entire phone freezes and won't work anymore. The time between my phone working and receiving the "stopped working" sign varies from 10 seconds to 2 minutes each time. If I lock the screen, it won't turn back on.

    The only way I can get it to run again is if I restart it, but only for a short amount of time before seeing the error again. I've already emptied the cache from my launcher in Apps and ran every test I could on my phone but no luck.

    I could try emptying the launcher's cache data but it sounds risky and may not work.

    Do you know what I should do? Please help me, my family is relying on me and I need a phone to communicate with them.
    Welcome to Android Central!

    Sorry to hear about the issues you are having. Sounds like something go messed up from the fall. You can try doing a factory reset to see if that fixes it but more than likely you might need to send it to Motorola to have them look at it.
    11-19-2015 07:37 AM

Similar Threads

  1. Replies: 1
    Last Post: 11-19-2015, 07:35 AM
  2. Why won't my phone connect to my PC?
    By AC Question in forum HTC Wildfire S
    Replies: 1
    Last Post: 11-16-2015, 06:28 AM
  3. Replies: 1
    Last Post: 11-16-2015, 03:36 AM
  4. I have a Tab 3 and heaps of photos, how do I make them into albums?
    By AC Question in forum Samsung Galaxy Tab 3
    Replies: 1
    Last Post: 11-16-2015, 03:34 AM
  5. Uninstalled app gets installed back after I power on my Android phone, why?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 11-16-2015, 02:16 AM
LINK TO POST COPIED TO CLIPBOARD