1. SupermanMikail's Avatar
    For about a week now, I have been getting an error message when trying to attach and send an image using the in-house text message app. All it says is "Unable to attach file.", nothing else.

    The interesting thing is that if I go to my photo gallery, click on the image, and then share it that way, then it works. I have done a lot of reading online and it looks like other people are having the same problem; it started recently.

    Does anyone know what is going on? I have cleared the cache, restarted, checked my settings, etc, etc.

    Any help would be appreciated. Thank you.
    12-06-2015 08:16 PM
  2. Laura Knotek's Avatar
    Hi and welcome to AndroidCentral.

    Which phone do you have?
    12-06-2015 08:50 PM
  3. SupermanMikail's Avatar
    I have the Samsung Galaxy Note 3.
    12-06-2015 08:59 PM
  4. SupermanMikail's Avatar
    Ladies and gentlemen, I think I figured this out. I cleared the default gallery that I was using (i.e., Google Photos) and tried a different gallery. It worked! Consequently, this leads me to believe that an update to the Google Photos app must be buggy.

    If you are having this problem, then try clearing the photo gallery default.
    charwink likes this.
    12-06-2015 09:17 PM
  5. charwink's Avatar
    I had been having the same problem since I updated my Galaxy s5. My default gallery was Google photos. As soon as I switched to the Samsung gallery, it began working again. Bummer, though. Hopefully this gets resolved, as I liked Google photos as my default gallery.
    12-11-2015 08:41 PM
  6. AMG1978's Avatar
    2 days ago I switched to a Google Nexus 5 to a Galaxy S6 and any photo I took ON the Galaxy S6 that is in my Photos, I can send via MMS. Any photo in my Google Photos that was taken on my N5, gives me the "Unable to attach" error.

    Nice.
    12-16-2015 02:10 PM
  7. Bobbl1235's Avatar
    Been fighting with this "unable to attach file" issue for a few months now on my Samsung S6 Edge. Can't seem to get a definitive answer on what causes/caused this to start happening, but I personally believe that it is tied to one of my carrier's phone updates (mine is Verizon). I've tried everything to get it to work again. I tried using different gallery apps, etc... I've even factory reset my phone which cured it for a small while before doing it again (I think this was because after doing a factory reset, the latest update was applied, and it stopped attaching files again). So I was about to do another factory reset when I noticed on the S6 Edge under Settings/Backup and Reset that there were two reset options 1) Factory Reset and the other 2) Reset Settings. I hadn't noticed the "Reset Settings" option before, but thought I'd try it. Sure enough that fixed the problem, and I didn't have to go through restoring my apps and files to get it back to my normal. This is just an FYI for others who are frustrated by this issue. Regards!
    04-02-2016 12:46 AM
  8. amyfenn1's Avatar
    I don't have the option Reset Setting under Factory Reset! AT&T sent me a new phone because I had this problem on my previous one, and it has started again. I think I may switch to an iPhone over it. It's ridiculous that it hasn't been fixed.
    04-08-2016 10:10 AM
  9. kam_zilla's Avatar
    have you tried uninstalling and reinstalling just the app. works for me and is better than resetting the phone. i have a s7 edge and it started happening after an update for me
    04-21-2016 06:44 PM
  10. Vycker's Avatar
    I have Galaxy S6 and after Samsung update, message plus was all messed up, went into application and uninstalled updates and back to normal
    02-07-2017 03:08 PM

Similar Threads

  1. Image app suggestion is needed, thanks
    By losl in forum Google Nexus 5
    Replies: 2
    Last Post: 12-07-2015, 05:14 PM
  2. My phone contacts will not load to my car
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 12-07-2015, 03:33 PM
  3. How can I root my Android Blu?
    By AC Question in forum Blu Android Phones
    Replies: 1
    Last Post: 12-07-2015, 04:39 AM
  4. SD card is not working... Help?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 12-07-2015, 04:38 AM
  5. Is Samsung Pay coming to the Gear S2 soon?
    By gspam1 in forum Samsung Gear S2
    Replies: 1
    Last Post: 12-07-2015, 01:07 AM
LINK TO POST COPIED TO CLIPBOARD