1. AC Question's Avatar
    I received an automatic message from Red Box about deals, and I tried to response via text to accept, and I received a notification box asking me to allow it because I would be charged normal texting rates. I accidently clicked "never allow", and now I cant undo it.
    For example, I tried to set up text message alerts from Amazon and and I wasn't able to verify because my response won't send...
    MLazarusM2 likes this.
    12-07-2015 12:14 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Not sure if this will work, but to go Settings>Apps>All, select Messaging, and Clear Defaults.
    12-07-2015 01:38 PM
  3. Josh1710's Avatar
    Ive Got an LG G5 and i said never allow. And cant send out a message. Ive tried everything suggested. Spent so much time go through all the settings. Please if someone has a solution.
    MLazarusM2 likes this.
    12-25-2016 12:01 PM
  4. Laura Kay Hegenberger's Avatar
    Galaxy On 5, Android 6.0.1, same issue.

    fixed, steps taken:

    Go to Settings
    Go to Applications
    Selcet menu in top right corner "show system apps"
    Scroll down to "Messenger Service", select
    Select "Send premium text message"
    Choose option from drop down menu.

    Attatching screenshots.
    Attached Thumbnails I do I undo a "Never Allow"?-20170621_131831.png   I do I undo a "Never Allow"?-20170621_131854.png   I do I undo a "Never Allow"?-20170621_131922.png   I do I undo a "Never Allow"?-20170621_131953.png  
    Usman R and MLazarusM2 like this.
    06-21-2017 11:39 AM
  5. KhMama's Avatar
    Fixed on Galaxy S8, similar to directions in the previous reply, except:
    Instead of "show system apps," select "special access" from the menu in app settings. Then, the premium message setting is there to change.

    There really should be a way to get to this setting thru the messaging app. Or at least thru the settings for that app
    -_-
    melissajane39 and MLazarusM2 like this.
    09-05-2017 02:07 PM
  6. melissajane39's Avatar
    I made this same mistake on my HTC Desire Eye, Android 5.0.2. This thread have me a good place to start to find the fix for my phone. Go to:
    Settings-Apps-All- scroll down and click on the "Messages" app. There is a section called "Permissions" where you can choose the "send premium sms" settings. Hope this helps!
    01-24-2018 02:39 PM
  7. jetgrrrl's Avatar
    Thanks everyone - between all your solutions I was able to find the setting in my wee old Samsung Galaxy S5 mini eventually!!
    Tim1954 likes this.
    04-30-2018 05:00 AM
  8. Usman R's Avatar
    Thanks A Lot

    Worked In My Phone
    05-24-2018 04:14 AM
  9. Eusebio Patiga's Avatar
    I also made the same mistake of my Samsung Galaxy J2 Prime. How to fix this?
    07-17-2018 11:59 PM
  10. LMixer18's Avatar
    I am currently having the same situation on my Samsung Galaxy S7. Anyone know how to fix it on a s7? Please help!
    08-08-2018 11:04 AM
  11. Shayne16's Avatar
    Does it work. Because I did that steps and now I don't know what else to do unless it did work

    How do you do this
    08-23-2018 12:03 AM
  12. Cassidychitwood's Avatar
    Go to settings
    Apps
    Right corner click the drop menu
    Then click special access
    Now select use premium text services
    Then click: ask, always, or never.

    This is a galaxy s9+
    Attached Thumbnails I do I undo a "Never Allow"?-screenshot_20181122-122814_settings.jpg   I do I undo a "Never Allow"?-screenshot_20181122-122820_settings.jpg   I do I undo a "Never Allow"?-screenshot_20181122-122824_settings.jpg   I do I undo a "Never Allow"?-screenshot_20181122-122828_settings.jpg  
    11-22-2018 12:33 PM
  13. md Enxio's Avatar
    You need to download a new messenger app. Try to get a ligit one. Set the new messenger to default and the premium message will pop up on that. You can send the message now but it will ask for permission again. DO NOT click never allow. Lol nvm
    01-12-2019 05:20 PM
  14. Lucy Mies's Avatar
    I use a Moto g6 and I recently had this issue. I believe this is Android 8 that I'm working with. what you have to do is
    Settings > Apps > Advanced and scroll to the bottom > Special App Access > Premium SMS access then change it to ask or always
    Attached Thumbnails I do I undo a "Never Allow"?-screenshot_20191010-080642.jpg   I do I undo a "Never Allow"?-screenshot_20191010-080647.jpg   I do I undo a "Never Allow"?-screenshot_20191010-080653.jpg   I do I undo a "Never Allow"?-screenshot_20191010-080658.jpg   I do I undo a "Never Allow"?-screenshot_20191010-080704.jpg  

    10-10-2019 10:13 AM
  15. MLazarusM2's Avatar
    Thank you. It didn't quite work, as its 2+ years later, but I was no where close to a solution, then KhMama's solution worked on my Galaxy S10e
    Instead of "show system apps," select "special access" from the menu in app settings. Then, the premium message setting is there to change.
    11-21-2019 07:18 PM

Similar Threads

  1. Replies: 7
    Last Post: 12-08-2015, 07:09 PM
  2. Replies: 1
    Last Post: 12-07-2015, 01:51 PM
  3. How do I find my wireless router?
    By So I have to sign up? in forum Ask a Question
    Replies: 2
    Last Post: 12-07-2015, 03:34 AM
  4. How do I delete ice from my Alcatel One Touch Pop?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 12-07-2015, 03:33 AM
  5. How do I get into my phone
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 12-06-2015, 11:47 PM
LINK TO POST COPIED TO CLIPBOARD