1. AC Question's Avatar
    I upgraded my Samsung Galaxy S5 to an S6, so I popped out the micro sd card from the old phone. Since the S6 has no external sd card expansion, I figured that I would just read the photos (the only thing I care about) from the old card when I got home.

    But the microSD is not readable. The partition table looks good, I see that it says it's a FAT32 file system, but I can't mount it.

    !!?? I no longer have the old Galaxy S5! How can I get my photos off my old micro sd? Does Samsung's Galaxy S5 use file system encryption or something?
    12-21-2015 01:46 PM
  2. AlphaTango414's Avatar
    Doesn't encrypt it unless you choose for it to. How are you trying to get the card to read on your PC?
    12-21-2015 02:26 PM
  3. James Welcher's Avatar
    Thanks for letting me know that encryption isn't normally a thing. I have a sdCard to USB adapter. The Mac responds with typical "The disk you inserted was not readable by this computer." Initialize... / Ignore / Eject

    I "Ignore" and the device shows up as /dev/disk4 and /dev/disk4s1, which means the partition table is recognized, and it knows there is a real partition there. But it's not being recognized as FAT32? I can read from the partition table:

    # mmls /dev/rdisk4
    DOS Partition Table
    Offset Sector: 0
    Units are in 512-byte sectors

    Slot Start End Length Description
    00: Meta 0000000000 0000000000 0000000001 Primary Table (#0)
    01: ----- 0000000000 0000002047 0000002048 Unallocated
    02: 00:00 0000002048 0124735487 0124733440 Win95 FAT32 (0x0c)

    But the file system isn't recognized as FAT32:

    # fsstat /dev/disk4s1
    Cannot determine file system type

    Can't manually mount it either.
    12-21-2015 03:56 PM
  4. James Welcher's Avatar
    Ok, just to close this out for anyone who comes across this in the future...

    I was getting the same error on Mac and PC. The volume just never appeared mountable. But... I had the micro sd card in a "MicroSD to USB3" adapter. After dumpedduce confirmed that it "probably wasn't" encrypted, I thought maybe there was something weird with the adapter. I plugged it into a "MicroSD to USB2" adapter that I had... same story on the Mac. "The disk you inserted was not readable by this computer."


    I then tried the USB2 adapter on Windows. BAM. It could read it. So... I still do not know why the Mac couldn't read the FAT32 image (I haven't see that before actually, I *frequently* move FAT32 file systems back and forth between windows and Mac). So, I was able to read all of the photos off the microSD card using a USB2 adapter on Windows. I also crushed the USB3 adapter under my boot-heel, just on general principles.
    12-21-2015 05:20 PM

Similar Threads

  1. Replies: 31
    Last Post: 12-22-2015, 02:43 PM
  2. My First Few Days On Project Fi ...
    By ejb1013 in forum Google Project Fi
    Replies: 5
    Last Post: 12-21-2015, 08:15 PM
  3. Replies: 3
    Last Post: 12-21-2015, 02:24 PM
  4. Replies: 0
    Last Post: 12-21-2015, 01:41 PM
  5. Replies: 0
    Last Post: 12-21-2015, 01:40 PM