1. AC Question's Avatar
    I recently updated my software from Android 5.1.1 to Android 6.0, and before the upgrade i could access all files on SD and internal storage through my PC. But now i am not able to. Selecting MTP on connecting to PC only shows files in my internal storage, my SD card reads empty.
    01-07-2016 08:12 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Are you using the SD card as adoptable storage?
    Laura Knotek likes this.
    01-07-2016 12:51 PM
  3. moch93's Avatar
    Iam having the same issue and I'm not using SD card as my primary storage. Any help ??
    01-09-2016 12:35 AM
  4. dhawal_reddevil's Avatar
    Facing the same issue after the update. SD Card shows up as empty on a Windows 10 PC.
    Internal memory seems to be showing all files correctly.
    I am not able to access my SD card contents on Moto X Play running Marshmallow through Windows PC-issue.png
    appy_mnm likes this.
    01-11-2016 02:57 PM
  5. sva999's Avatar
    before marshmallow I could copy/save music files on San Disk 32. After marshmallow, Nada! just shows Moto G3 in folder tree, but cant open it. Many other similar posts here - sounds like a bug - a big F*** bug!
    01-11-2016 04:10 PM
  6. B. Diddy's Avatar
    Have any of you tried wiping the cache partition, as a general troubleshooting step? https://motorola-global-en-aus.custh...p/30,6720,9392
    Laura Knotek likes this.
    01-12-2016 10:57 PM
  7. appy_mnm's Avatar
    I have the SAME issue! chose sd card to serve as a portable memory rather than internal. Its really annoying and totally unacceptable. Marshmallow update has caused more problems rather than solving it.
    PS Why on Earth wont the sd card contents show up?? i cant risk clearing the cache partition too. what if it formats or deletes something.
    01-16-2016 09:17 AM
  8. B. Diddy's Avatar
    Clearing the cache partition will not delete any personal data. Cached data is always meant to be temporary.
    Laura Knotek likes this.
    01-17-2016 02:18 AM
  9. sva999's Avatar
    Best fix I've seen so far:
    When connecting to PC, you'll get a notification that says 'charging with USB'. Tap the notification to get more options, then select Transfer data. You'll have to do this every time you connect.
    02-06-2016 12:30 PM
  10. JohnNorthey's Avatar
    A very frustrating problem. Switching the USB settings to just allow access doesn't work (SDCard comes up blank - no files or anything but does say how much space is used/available). Did the cache wipe (took a long time) and still no luck. Bloody piece of junk, doesn't have an easy way to access the SD card either.
    02-09-2016 01:59 PM
  11. JohnNorthey's Avatar
    Argh. Finally found where the card was hiding. Needed that tiny tool they give you to pop it open (I suspect a needle would work too) at the top of the phone (my phone case hid it). Luckily my tablet works as a micro SD card reader too.
    02-09-2016 02:04 PM
  12. jobinjoph's Avatar
    am also facing the same issue.. anyone got any kind of Fix for this,
    03-14-2016 05:00 AM
  13. Peter Holt's Avatar
    I found this answer on another forum and it worked for me.

    I had the same problem with my Moto G 2015 after upgrading to MM. On the Phone it would see the card and I could view all my files (mostly photos). But after connecting on a USB link to my computer, it would see the SDcard, but not show any files.

    I turned off the Moto G Phone, took out the SDCard, and booted up. Then I turned off the Moto G Phone again, put the SDCard back in, and booted up again. Voila! I can now see the files on the SDcard.

    Hope this helps!
    03-20-2016 01:21 AM
  14. dsripad's Avatar
    Yes, the last suggestion of switch off ->remove SD card->switch on->switch off->insert SD card->switch on - worked for me. Of course as per other suggestions I did clear the cache partition which by itself did not work. Looks like removing and inserting the SD card rebuilds the cache all over again.

    05-16-2016 10:38 AM
  15. BogasBuggerTheFirst's Avatar
    Thank You. You just saved me a lor o angst and frustration. Worked like a charm.
    07-13-2016 06:31 PM
  16. BogasBuggerTheFirst's Avatar
    I found this answer on another forum and it worked for me.
    Thank You. You just saved me a lot of angst and frustration. Worked like a charm.
    07-13-2016 06:33 PM

Similar Threads

  1. Unable to delete individual call log history from Nexus 6
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 08-11-2016, 09:55 AM
  2. Replies: 1
    Last Post: 01-07-2016, 09:09 AM
  3. why my huawei g6 u10 gallery has n issue
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-07-2016, 07:54 AM
  4. Replies: 1
    Last Post: 01-07-2016, 07:54 AM
  5. Why are my emails all going into a combined inbox?
    By AC Question in forum General Help and How To
    Replies: 2
    Last Post: 01-07-2016, 07:50 AM