1. AC Question's Avatar
    I have an unrooted 1st gen Moto 4G running Lollipop 5.1 and my google app seems to have reverted to stock app (old icons and so on). If I go to the play store it says my device is not compatible. It worked just fine until yesterday :/ Same goes for google play services. I already tried a factory reset and no joy. Any help would be much appreciated.
    02-17-2016 06:49 PM
  2. Nick Loehr's Avatar
    I've been having this issue too, all of a sudden all of my devices are unable to update the google app either.

    if you really need to update to the most recent version, apkmirror is a good option, as long as you have unknown sources checked in settings.
    02-18-2016 05:49 AM
  3. shadower's Avatar
    Same thing here, since yesterday google app icon reverted to blue and white after factory reset and google play says my device (s6 edge plus) is not compatible with the version on the google play store.
    contacted google and they don't seem to be aware of anything
    02-18-2016 12:00 PM
  4. Christopher R's Avatar
    Same issue here. Just yesterday everything changed .
    02-18-2016 01:57 PM

Similar Threads

  1. Can I root my Samsung Galaxy (samsung-sm-g900a) Running Android Version: 5.0 on AT&T
    By SoulDeep in forum Samsung Galaxy S5 Rooting, ROMs & Hacks
    Replies: 5
    Last Post: 04-03-2017, 11:23 AM
  2. How can I get rid of tojan virus Android.Troj.Riskroot.z?
    By AC Question in forum Ask a Question
    Replies: 16
    Last Post: 02-19-2016, 02:52 PM
  3. Update killed my battery
    By medic078 in forum LG G4
    Replies: 4
    Last Post: 02-18-2016, 05:33 AM
  4. What is the best download app
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 02-18-2016, 03:02 AM
  5. how can i prevent location being turned off
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 02-17-2016, 06:18 PM