1. AC Question's Avatar
    I tried to root my phone recently. It is a HTC one SV from Boost.
    I unlocked it but I couldn't root it. Recovery Mode was not working for me after hours of trying to fix it. So in frustration, I used the adb command to install Superuser.apk file and then this almost totally bricked my phone.
    I tried many things and nothing seems to work.
    It turns on to bootloader only, everything else gets stuck on HTC screen.
    There is some hope I think. Flashing TWRP.img gets me a flickering screen a circle with blue arrows from what I can make out.
    Can someone help? Or point me in the right direction?
    03-03-2016 03:35 PM
  2. Denny P2's Avatar
    Download this recovery https://twrp.me/devices/htconesvboost.html Than flash it from fastboot with the command:
    fastboot flash recovery TWRP.img
    Replace TWRP.img with the full path to the recovery file. After that reboot in to recovery mode and flash this ZIP http://downloads.noshufou.netdna-cdn...arm-signed.zip.

    If you further damage your device I'm not responsible.

    [GUIDE] Root for HTC One SV UPDATED 23/02/13 | HTC One SV
    03-04-2016 12:57 AM
  3. herim's Avatar
    thanks for reply.
    However I still have the first issue. I cant enter Recovery Mode correctly.
    It enters but the screen flickers on for less than second. I am unable to use recovery mode. How can i get that to work.
    03-04-2016 06:18 PM
  4. Denny P2's Avatar
    Did you flash with the exact recovery image I gave you? Is your bootloader unlocked? And could you poat the beggining of your HBOOT screen?
    03-04-2016 11:23 PM
  5. herim's Avatar
    Ok for anyone else having a similar issue. Here is what I did.
    1. My device was flickering with the twrp files I was using to fix that I had to use an older file not the oldest one. I used version. That got me into recovery twrp.
    2. I was not able to boot my device. So what I did was use the RUU from HTC for my One SV. That replaced the damage I did to the files.
    3. After that I used windroid tool kit to flash their superuser file. MIne wasn't working.
    4. I went back into twrp recovery and installed their superuser file. I had do it twice for some reason.
    After that I achieved Root. Now to bigger and better things to corrupt my phone.

    Thanks a bunch for your help Denny I appreciate it.
    Denny P2 likes this.
    03-07-2016 12:14 PM

Similar Threads

  1. Deleting Samsung Account from my Note 4, can I get some assistance?
    By Nick_1020 in forum Samsung Galaxy Note 4
    Replies: 3
    Last Post: 03-06-2016, 06:47 AM
  2. Replies: 3
    Last Post: 03-06-2016, 01:00 AM
  3. How do I fix this sh!tty device?
    By Banchoukakarot in forum Android 4.4 KitKat
    Replies: 2
    Last Post: 03-04-2016, 10:37 AM
  4. Replies: 1
    Last Post: 03-03-2016, 03:21 PM
  5. Facebook with free data?
    By chefmorry in forum Android Apps
    Replies: 0
    Last Post: 03-03-2016, 02:53 PM