1. AC Question's Avatar
    I have a couple of months to use my Asus ZenPad 8.0. When I tried to turn it on, it didn't, so I presumed that it was uncharged. I left it for several hours to be charged but when I tried to turn it on, I couldn't.
    Keep in mind that I have used it just for a couple of times and I bought it on January.
    Any suggestions?
    03-09-2016 03:19 AM
  2. AlphaTango414's Avatar
    Try charging it with a different charger, cable, and outlet. Does any notification pop up that it's charging when you plug it up?

    Try to boot into safe/recovery/download mode.
    03-09-2016 04:19 AM

Similar Threads

  1. QR code on back?
    By soboness5 in forum Samsung Galaxy S7 edge
    Replies: 8
    Last Post: 09-12-2016, 02:18 PM
  2. Replies: 2
    Last Post: 03-15-2016, 07:55 AM
  3. Always on display
    By mikeoc in forum Nexus 6P
    Replies: 2
    Last Post: 03-09-2016, 08:52 AM
  4. Replies: 1
    Last Post: 03-09-2016, 06:49 AM
  5. Gear S2 data not showing on S Health
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-09-2016, 03:12 AM